Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   hard pedel slow stop (http://www.hotrodders.com/forum/hard-pedel-slow-stop-170205.html)

campracing 12-19-2009 08:26 PM

hard pedel slow stop
 
ok here is the story i have replaced the two front calipers pads hoses rotors and MC. then i swaped the rear end from a 69 chevy truck in to the 81 chevy truck the rear still has drums on it. after bleeding all the air out now the pedal is hard to push and the truck does not want to stop

any ideas

pepi 12-19-2009 10:53 PM

If they are power brakes sounds like no assist .. check the booster operation

sqzbox 12-20-2009 05:22 AM

Have you adj. the rear shoe's? clearance is critical on rear drum and front disc
combinations. Too much clearance between the rear shoes and the drum will make the front disc's work harder with less stopping power. That might be your problem as if you need to use both feet on the brake peddle to stop.
You can check your power brake booster by starting your engine and shutting it off then pop the vacuum fitting off the booster. If it doesn't have a wooshing sound, your loosing brake assist from the booster because of a bad diaphragm causing a vacuum leak. This will also cause erratic idle problems but will still run smooth going down the road. :cool:

pepi 12-20-2009 07:50 AM

Apply pressure to the brake pedal and start the motor. The peddle should move down a bit indicating that the booster is working . Check the MPB site they have some very good accurate troubleshooting methods.

One other item do you have a disk too drum proportional valve in there? If that ruck had disk, 4 wheels The new rear has drums then the proportional valve hanging under that MC needs to be changed ....

campracing 12-20-2009 02:47 PM

thanks guys i will check the booster

the truck came with disc/drum

i think it was a vacuum problem i just put the motor back in and the timming was way off so big cam little vacuum no brake assist :nono:

sqzbox 12-20-2009 07:26 PM

And now, the rest of the story!!!! BIG CAM, LITTLE VACUUM. That explains everything.
Sounds like a vacuum resivour will be in your future. :cool:

campracing 12-21-2009 01:17 PM

Quote:

Originally Posted by sqzbox
And now, the rest of the story!!!! BIG CAM, LITTLE VACUUM. That explains everything.
Sounds like a vacuum reservoir will be in your future. :cool:

lol probably so.....it is getting better thought

red65mustang 12-21-2009 01:34 PM

the booster stores 3-5 brakes applications typically by means of a one way check valve where the hose connects....

to have pb with a big cam just blip the throttle once in park/neutral so the booster receives a 18hg+ plus charge as the motor rpms decelerates back to idle...

every/anytime you back off the go pedal the Hg shoots to 25+ stored in the booster...
a good condition booster will store that vacuum charge overnight....

all that adding a canister/reservoir does is increase the volume to be charged,,,doesn't increase the Hg which is critical for the booster to operate

sqzbox 12-21-2009 06:09 PM

I'm guessing you have a stock converter? That "bliping" the gas and slipping into "N" get's old real fast. I had a Crower 3/4 cam at 280D/460L with stock stall converter and if I wasn't in nutral or decelerating, the brakes wre nill.
A vacuum resivour can, fixed that for me. I could have got a higher stall converter and raised my idle speed but the cool "LOPE" of the cam wouldn't have been as profound at 1200 rpm. Besides that, My milage would have sucked as I ran 3:54:1 rears and made monthly 1000mi trips to San Diego from AZ. I still got 16-17 mpg and ran 14's at the track, and several win's at autocrossing. The biggest problem before the resivour was at low speed or at idle when parking. After the first stab on the brakes, the assist went away. Needles to say I've bumped into two cars and lucky me, happened to be friends and not much damage. The thing that was the worst was the "freak out factor" when you stand on them with both feet and it keeps rolling! :D

red65mustang 12-22-2009 05:53 AM

sqz,

my suggestion is for you to do some reading in the "knowledge base" link at the top of the page...

mega cam/low idle Hg = they make a electric vacuum pump system to feed the booster so the booster never sees less than 18Hg....
(if you don't want to blip the throttle in P/N to charge the booster)

your canister "fix" cure proved the whole brakes system needed close inspection...

sqzbox 12-22-2009 08:09 AM

RED The car was a 1971 Javelin with vacuum wipers that ran off the double dia. fuel pump! Can you believe that? :eek:
If it sprinkled at the drive in, I had to start my car to wipe the windsheild.


All times are GMT -6. The time now is 10:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.