Haven't Posted In Awhile - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-04-2006, 08:42 PM
Registered User
 
Last photo:
Join Date: May 2005
Location: NJ
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Haven't Posted In Awhile

Hey guys whats up?? Haven't posted in quite some time, I used to hang around the paint/body work section...before I was getting info on my Iwata LPH400, well over the past year a lot has come together. I finally got my booth cleaned out and about 80% finished, and I have got much better in laying down clear and I'm now starting to venture into the world of painting more and getting ready for some fun stuff, I'm hoping to start my dream project (32 Hi-boy) w/in the next yr or so.

I know it's not a hotrod but I figured I'd post up some pics of my last project which I finished up last week, all in all it was quite a bit of time to get to the finished project but it was worth it and we are now looking at a potential sponsorship

Specs on the paint I used Finish Pro 2 part primer, Omni Plus Paint, and PPG Flexed and Fit Clear (0-5% gloss)

Here ya go:










    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-04-2006, 08:49 PM
Henry Highrise's Avatar
Lost in the 60's
 
Last wiki edit: Removing stuck fasteners Last photo:
Join Date: Dec 2001
Location: Dixieland
Age: 69
Posts: 15,189
Wiki Edits: 4

Thanks: 0
Thanked 11 Times in 10 Posts
Looks like ya did a good job!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-04-2006, 08:56 PM
Member
 
Last photo:
Join Date: Nov 2003
Location: Green Bay, WI
Age: 44
Posts: 2,073
Wiki Edits: 0

Thanks: 0
Thanked 6 Times in 6 Posts
Yeah lot of people have come and gone that have posted in the body forum, as well as a lot of new people. Glad you found your way back.
That sure looks nice. I haven't used omni's basecoat for quite awhile. I heard rumors the omni plus was nexa's value line called valupro. What did you think about the products you used and did the omni plus cover better then the regular omni?
Wish I had a booth. If I wasn't renting the place, I'd build something nicer then what I've got to work with. Sure would save a lot of time and be easier to paint in.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-04-2006, 08:59 PM
Registered User
 
Last photo:
Join Date: May 2005
Location: NJ
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I never used the oiginal Omni, but I think it layed down just as good as RM or better, the price was right and I'll keep using it!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-04-2006, 09:42 PM
Member
 
Last photo:
Join Date: Jan 2005
Location:
Posts: 3,707
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Welcome back, I haven't seen the Omni Plus in this area yet.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-04-2006, 10:07 PM
Registered User
 
Last photo:
Join Date: May 2005
Location: NJ
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I should have a few more projects over the next few weeks using the Omni Plus and I'll be using a regular high gloss clear so I'll be posting more pics as I move along, I also plan on hanging around a bit more now that I have my booth and can paint on a more regular and easier basis
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-05-2006, 01:23 AM
Ranchero_65's Avatar
Member
 
Last photo:
Join Date: Sep 2003
Location: Roseburg , OR
Age: 60
Posts: 150
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hey I thought you were lost but guess not
Nice work on the bike
Take Care
Earl
Reply With Quote Quick reply to this message

Recent Body - Exterior posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
It's Been Awhile..... RCastle Off-Topic 5 06-22-2006 08:28 PM
Saying hey again (been gone awhile) Shades_o_Grey Introduce Yourself 1 09-22-2004 11:00 PM
Been away for awhile 327ImpalaSS Hotrodders' Lounge 3 07-11-2003 02:47 AM
It's been awhile crshrmn3 Hotrodders' Lounge 1 05-19-2003 05:21 AM
Been awhile........... DragLinkscc Hotrodders' Lounge 7 11-08-2002 04:57 AM


All times are GMT -6. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.