Having problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-27-2011, 09:21 AM
Registered User
 
Last photo:
Join Date: Apr 2011
Location: North East Texas
Age: 32
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Having problems

A friend of mine built a 383 stroker and we put it in my truck. The 350 has a set of 882 heads and we put the edelbrock stage 2 manifold on it and a adapter plater so that I could run my 670 Holley T.B.I. on it, and when I take off it wants to die if I give it to much gas but once it is going it does great. If I rev the engine to two thousand RPM it sounds fine but below that it is very rough idleing. It has a 2000 rpm stall in it. My question is that I need to know if that the TBI is ok to run on there or do I have to go to a 4 barrel and if so, does it have to be a carburetor or will a 4 barrel TBI work. I really dont want to have to switch it over to carb and take my computer out and add all the extra parts to switch it. But I need to know if I'm throwing money in the wind or can I keep the TBI and computer. Thanks for your time and I am looking forward to some replies. Yall have a great day. The truck is a 94 Gmc sierra it has a JET stage 1 chip on the computer and a MSD performance coil pack. If you need any more information please ask.
Attached Thumbnails
Click image for larger version

Name:	truck.jpg
Views:	43
Size:	9.2 KB
ID:	54697  
Attached Images
File Type: jpg 100_2514.JPG (834.3 KB, 43 views)
File Type: jpg 100_2515.JPG (812.1 KB, 47 views)

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-30-2011, 11:34 AM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
I doubt the parameters of the Jet stage 1 chips will be enough. 670 CFM is sufficient but you will need to contact them (or someone else) regarding a chip.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-01-2011, 06:35 AM
Registered User
 
Last photo:
Join Date: Apr 2011
Location: North East Texas
Age: 32
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thank you

I believe that I have to have a custom chip made for it since it is so much of a difference. I am having a hard time finding someone local so I have done some research online and found a few places that do custom chips. I do not think the stage 1 chip is enough either. I thank you so much for you advice.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
454 problems lowdually Engine 4 05-26-2009 05:21 AM
305 problems andrew.loesch Engine 2 05-25-2009 01:13 PM
HEI problems--- help blownalkybbc Electrical 8 07-01-2006 09:23 PM
Lifter Problems/Head Problems lewisdanw Engine 4 04-16-2006 01:47 PM
Gen 5 454 problems t/a clone Engine 5 12-11-2005 09:44 AM


All times are GMT -6. The time now is 09:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.