Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Heater Hoses/Firewall Problem (http://www.hotrodders.com/forum/heater-hoses-firewall-problem-58461.html)

EazyDuzIt102 02-18-2005 10:17 AM

Heater Hoses/Firewall Problem
 
Hey everyone.I got a 1965 Impala SS and I am having a problem the the lower heater hose on the firewall.I started the car the other day and I noticed that the bottom hose was leaking.So I went to tighten the hose clamp on there and noticed that the part coming out of the firewall(That the hose connects to)was really loose.The stuff holding it on there was rotted out.How do I fix this?It looks like they just put a bunch of silicone around it to keep it sealed because the hole in the firewall is bigger than the the part the hose connects to.Is there something I can buy so it will fit properly or am I suppoed to just put silicone around it and stick it back in?Someone please help.Thanks,

Eazy

NovaSS350 02-18-2005 10:45 AM

Your heater core is probably rotted out. Not to hard to replace or if you don't use your heater you could just remove it entirely. Normally accessed under the dase or could be through the front cover.

bracketeer 02-18-2005 10:58 AM

heater hose
 
Rtv works well and is easy to remove.

MI2600 02-18-2005 01:45 PM

It sounds like the inlet has broken loose from the heater core. The only real way to fix this is to remove and fix the core. You could probably cobble up a temporary fix with the silicone, but it sounds as though it's been leaking a while and you really don't know what the core itself is like.

I don't know if you can remove the core without removing all the heater housing from the firewall. That involves almost removing the fender. When ours came loose we had the entire front end off.

I would also recommend you check your front passenger floor for damage.

orian 02-18-2005 02:40 PM

I had a similar problem with my '64. I replace the heater core, it was leaking at that stub out. On the '64 you access it from under the dash and was a pretty simple deal. I bought the replacement through NAPA. I don't remember the cost, but do remember that it seemed reasonable.


All times are GMT -6. The time now is 09:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.