HEI distributor - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-20-2010, 08:19 PM
Registered User
 
Last photo:
Join Date: Jun 2009
Location: Michigan
Posts: 32
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
HEI distributor

I have a 1977 350 sbc I rebuilt this fall and winter (mild performance cam change as well as an intake change), and my concerns started out with a poor idle. The advice I got was to set up 36* mechanical advance and the turned into that the distributor could not get up 36* at an initial base timing set of 12*. Ok, so I put on some lighter springs, no change. Took off the springs, no change. So there is no way I am going to get 24* mechanical advance from my HEI. What is the issue that I am having? Should it not peg out at 36* without spring at a 1500 or so RPMs. I am certainly not getting that much advance with stock or light springs at 2800 RPMs. What should I try? Another issue is that now that I have pulled the distributor to get a closer look, I noticed a lot of play (1/8" or so) at the end of the shaft between the housing and the gear. Logic tells me that this could cause some timing issues with the gear potentially moving up and down as the engine ran. Is there a fix for that or is the distributor need to be replaced. The distributor looks clean and the like with little wear, but I am not sure what my next step is with this thing.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-20-2010, 08:59 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,643
Wiki Edits: 0

Thanks: 13
Thanked 56 Times in 53 Posts
Machanical advance does not work at idle, it`s only use is off idle, centrifical force is what advances it. Connect the vacuum advance to a full time manifold vacuum port, one that pulls vacuum even at idle. Since you already had 12 degrees base timing, the vac advance will add another 10 to 12 degrees depending. After you connect it, recheck the base timing, it should be 20-24 degrees.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-21-2010, 12:34 AM
Registered User
 
Last photo:
Join Date: Jan 2006
Location: Nanaimo, B.C., Canada
Posts: 657
Wiki Edits: 0

Thanks: 1
Thanked 17 Times in 17 Posts
The springs don't regulate how much timing you get, they regulate at what RPM the timing advances. You need to use smaller pins or longer slots in the mechanical advance to get more timing. The vaccum advance should only come in in high vaccum situations such as cruising on the highway, usually to give you better gas mileage.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-21-2010, 02:20 AM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,643
Wiki Edits: 0

Thanks: 13
Thanked 56 Times in 53 Posts
Here we go again. Many ask why do you need vacuum advance at idle?
I used to ask that same question.
You need it because idle and off idle mixtures are lean, leaner mixtures burn slower, and when the mixture burns slow it needs more spark advance to compensate. Manifold vacuum works off idle just the same as ported vacuum. However, since the idle mixture is lean, it needs that extra spark advance when coming off idle to the main circuits, if not the engine will sometimes sputter. You have to remember, the power valve doesn`t kick in until the vacuum drops under a certain vacuum limit, during regular driving you won`t open the throttle enough to make the vacuum drop low enough for the power valve to enrichen the circuit so the mixture is still lean. Take any chevy vehicle from the mid 70`s to early 80`s. The catalyst says "timing set with vacuum advance disconnected and plugged" if it`s connected to a ported source there is no need to disconnect it, because it doesn`t pull vacuum at idle. When I ran my small block to a ported source, a mild 9:1 compression 350 with headers, small RV cam, intake and carb with 3.23 gears, it wouldn`t even spin a tire from take off, it was a dead player. For a long time I couldn`t figure out why it was so sluggish, until a member of this site told me to connect my vac advance to a manifold source, I did as he asked and the car felt like it picked up 50 horses. It had great bottom end torque and throttle sensitivity.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-21-2010, 02:28 AM
fast68's Avatar
likes chevy trucks & boobies
 
Last photo:
Join Date: Oct 2005
Location: IL
Posts: 1,970
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
set your base timing by posotion of the distributor

use vacuum advance if you need more advance at higher rpm

it uses a ported vacuum source on the carb

mechanical advance also works at higher rpm

alot of times i dont use vac advance, i dont even connect it, especially on stock cam engines,

as they run perfectly fine without it and get plenty enough advance from the mech weights already

to run fine.

overkilling ignition advance will cause problems quicker and worse than not having enough .

due to detonation/pinging from over advanced timing

use a timing gun to figure out your base timing and to see how much your advancing at what rpm levels

too much of it is the worst thing to have.,,
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HEI Distributor, no spark think I tried everything bradster79 Engine 14 07-25-2011 10:06 AM
lots of aluminum corrosion in stock HEI distributor fast68 Engine 1 08-31-2009 04:42 PM
Converting small chevy distributor to HEI bbcwgn Engine 2 11-28-2006 03:46 PM
HEI distributor and TPI 70bird Engine 7 04-19-2006 10:10 PM
HEI distributor - Which one? Eagle1 Engine 5 07-28-2004 11:46 PM


All times are GMT -6. The time now is 04:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.