HELP!!! Burnt Distro terminals - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-15-2005, 10:40 AM
interro1's Avatar
Until death does it backfire!!
 
Join Date: Jul 2005
Location: Raeford, NC
Age: 37
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
HELP!!! Burnt Distro terminals

Not too familiar with HEI but here goes

I pulled the distro cap off and found that my terminals, both on cap and rotor are burnt and there is residue all over the assembly.

Any thoughts?

(edit) I don't want to put the new one in and have it get burnt to a crisp the minute I start it up....

additionally....I don't know how long the other one has been in there.

    Advertisement

Last edited by interro1; 07-15-2005 at 11:44 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-15-2005, 11:44 AM
Jmark's Avatar
Registered User
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,824
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Its normal wear for the end of the rotor and the ends of the 8 cap terminals to be badly pitted and kinda burned looking. Time to replace them. A high milage cap and rotor will also burn the center post in the cap and the metal tab on the rotor. Again, just time for a change.

As far as the residue goes, it depends on what it is. If its a copper or redish color, its usually rust dust from the weight pivots. Again, fairly common but wear is not a good thing. A drop of oil on each pin won't hurt anything. A small amount of oil slung around the inside of the cap is common too. Some will work its way up the shaft and get tossed around by the reluctor. Not a biggie unless its really soaked inside.

Mark
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-15-2005, 11:47 AM
interro1's Avatar
Until death does it backfire!!
 
Join Date: Jul 2005
Location: Raeford, NC
Age: 37
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
sounds good....little oil in there....hopefully there's nothing wrong.

little dust in the weights area....might throw a bit of lube down there too...

thanks for the help...

oh and BTW.....I know you're a Savage fan...thank you for your support.

(I'm active duty...)
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-15-2005, 09:54 PM
johnsongrass1's Avatar
Race it, Don't rice it!
 
Last photo:
Join Date: Jul 2002
Location: Columbia, Mo
Age: 38
Posts: 4,080
Wiki Edits: 0

Thanks: 0
Thanked 10 Times in 10 Posts
A bad condensor will do it too.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Burnt Alternator Brushes ArnoldD Electrical 3 08-15-2004 11:21 AM
Burnt Points...Hot Coil? wickster Electrical 15 07-20-2004 08:54 PM
Rebuilt 700r4 Burnt in 10 miles subman17 Transmission - Rearend 9 02-15-2004 03:41 PM
almost new 454 with one burnt piston clyde Engine 2 01-12-2003 08:18 AM
hei distributer,burned or dirty terminals in cap what causes this? IHAVECHEVYPARTS Engine 3 11-19-2002 08:32 PM


All times are GMT -6. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.