Help With Head Gasket Question Please. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-02-2003, 05:57 AM
Member
 
Join Date: Sep 2003
Location: FL.
Age: 31
Posts: 38
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Help With Head Gasket Question Please.

Had a few question on the head gasket. Now i think i might have blown it but im not to sure. I came out of a gas station and stomped on it for some kids that were there and allmost in a instant the car started overheating and feels like im losing compression when i try to give it some gas. When im in neutrual and rev it nothing happens, everything is fine. But when I get on it when im driving is when i feel it. Its allmost like a sputter.

Also when i got home i checked out the engine and the top raiditor hose felt like it had a lot of pressure on it and the cap was poped up a little bit and flowing over. I checked my thermostat to see if it was stuck, only to find out that there wasnt one in there.

please if any one knows what might be wrong please help,

its a 289, with some mods, dont know if you might need the mods to help with problem but here you, it has a Torker intake, holly 650cfm 4 b double pumper, roller rockers, hooker comp. headers, it does have a diff cam but dont know what kind (my dad dont remember) and also the engine has been balanced and blueprinted (really dont know what that means) and a t-5 trans and 4.11 posi gears

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-02-2003, 08:17 AM
Wrencher's Avatar
Member
 
Last photo:
Join Date: Aug 2003
Location: cincinnati
Age: 56
Posts: 607
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
Install a thermostat and check your plugs and wires.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-02-2003, 08:27 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,212
Wiki Edits: 0

Thanks: 27
Thanked 292 Times in 272 Posts
Take the car to a mechanic, have him check for combustion gasses in the radiator (a dye is used), if so you have a head gasket leaking.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.