HELP!!!!! Moaning / Groaning Front Suspension?????? - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 05-11-2013, 05:18 PM
texastomeh's Avatar
Registered User
Last photo:
Join Date: Jul 2004
Location: Dallas, TX
Posts: 279
Wiki Edits: 0

Thanks: 18
Thanked 11 Times in 10 Posts
HELP!!!!! Moaning / Groaning Front Suspension??????

Have just finished(?) rebuilding most (new HD Sway Bar, New Poly Bushings, New Idler Arm Bushing, Shocks, Coil Spring Isolators, etc.) of my '63 T'Bird HT's front suspension. The Ball Joints and all of Tie Rod linkage and ends had been replaced by PO and were good and tight - so just replaced some torn boots and lubed good. Power Steering fluid was flushed and bled, and filter replaced. Works perfectly. All belts are nice and snug. Also did a "start-from-square-one" alignment.

Results? She rides and handles like a dream!! Only problem is that ocassionally when I am make a slow speed turn (eg; into driveway, at a stoplight or a corner in city driving) I hear a low level "Groan" / "Moan" (NOT a "squeal") from the fontend. Doesn't matter whether I am turning RIGHT or LEFT (although it does seem to be more prevalent during LEFT turns).

I can't seem to isolate it and, as expected, It doesnt occur when sitting in the diveway or garage with the hood up!

ANY help and/or suggestions would be GREATLY appreciated!!


Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 05-11-2013, 06:24 PM
Last photo:
Join Date: Dec 2004
Location: ohio
Age: 68
Posts: 694
Wiki Edits: 0

Thanks: 0
Thanked 51 Times in 48 Posts
Lube the Poly bushings, they are famous for this.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front Suspension BIASI Suspension - Brakes - Steering 3 06-20-2012 08:55 PM
C-4 front suspension Lil Joe Suspension - Brakes - Steering 1 11-09-2007 07:07 PM
front suspension rattymcratrat Hotrodding Basics 6 10-10-2007 09:59 PM
Front Suspension 53 Ford Front Clip PaulNJ53Ford Suspension - Brakes - Steering 2 08-11-2004 11:12 PM
Front suspension Vapor Suspension - Brakes - Steering 7 02-03-2002 06:28 AM

All times are GMT -6. The time now is 03:46 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.