HELP! My TH350 has puked! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-20-2001, 03:22 PM
The Vandal's Avatar
Engine Tech Addict
 
Join Date: Oct 2001
Location: Clinton, MS
Age: 43
Posts: 125
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post HELP! My TH350 has puked!

After a few hard launches in the driveway, my TH350 has puked most of it's fluid up through the dipstick. What have I done? Please e-mail me. Thanks -

Go hard, go straight.

[ October 20, 2001: Message edited by: The Vandal ]

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-25-2001, 07:43 PM
Registered User
 
Join Date: Oct 2001
Location: Lexington
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

You built up to much pressure from fast-hard take offs and blew up the pump :p
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-02-2001, 07:20 PM
New Member
 
Join Date: Sep 2001
Posts: 13
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

If you are getting it rebuilt. try going with a 400 stall converter on the 350 tranny and a shift kit. It will be more reliable and will work better. I had a tranny that did the same thing and it didn't last very long after it started. goo luck nick,
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-05-2001, 07:29 PM
The Vandal's Avatar
Engine Tech Addict
 
Join Date: Oct 2001
Location: Clinton, MS
Age: 43
Posts: 125
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Just thought I'd leave an update so you'll all know. Fluid wasn't showing on the dipstick at all so after adding the right amount it runs fine. Thanks for all your help. The Vandal
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.