Help please...no a/c or heat from vents - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-15-2005, 02:27 PM
Registered User
 
Join Date: Jul 2005
Location: New Jersey
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Help please...no a/c or heat from vents

I have an 82 trans am with a 305 carb...all of a sudden after only using the a/c after 5 minutes i have nothing comming out of the vents no matter what mode the control unit is in....the clutch isnt even engaging on the compressor in the on position,when i jumped the wires to the blower and ac compressor they worked, i put a new relay on there and still nothing, i jumped all the wires and all make connection no breaks....i changed the fan switch control unit and blower relay and still nothing....but everything works when i take power directly to it....i changed the reistor in the heater box and the blower switch in the control unit and now still nothing...im really lost please help.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-15-2005, 03:23 PM
35WINDOW's Avatar
Member
 

Last journal entry: Dash Mock-up
Last photo:
Join Date: Dec 2004
Location: utah
Age: 59
Posts: 1,395
Wiki Edits: 0

Thanks: 7
Thanked 21 Times in 19 Posts
Just a few guesses here,

Have you any access to A/C gauges to check the pressures? I don't always like to recommend this, but have you jumped the high and/or low pressure switches to see if the A/C clutch kicks in? (if it does, I'll bet you are low on Freon-low pressure). I assume that your car doesn't have an Automatic Temperature Control. It could also be the Thermo Switch-check the pressures and switches first-

Craig
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Big block S-10 a/c heat daily driver roadrash9r Engine 3 06-27-2007 09:11 PM
Help please...no a/c or heat from vents knightriider Introduce Yourself 1 07-14-2005 08:29 PM
1951 Buick Roadmaster a/c system madgift Interior 3 08-13-2004 07:49 PM
A/C vents stinky jinx Interior 1 04-27-2004 10:13 PM
A/C question Paco Engine 1 06-03-2002 07:01 PM


All times are GMT -6. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.