help with smoke - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-25-2005, 08:08 PM
Registered User
 
Join Date: Aug 2004
Location: Ft. Pierce FL
Age: 27
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
help with smoke

I bought a early 80’s chev 350 out of a ¾ ton van, to have rebuilt and dropped in my k10. I had the crank turned, block 30 over w/flat tops & Hasting rings, mild cam, new lifts & push rods. Total overhaul on heads, with larger intake valves and guides. New Performer intake toped with a used edelbrock 600 that I had rebuilt, and a new Mallory hei dist. Now for the problem….it smokes and burns oil and its well past its brake in. Is it possible that my pcv valve could be pulling oil into the carb? the pcv is new and I know my edelbrock valve covers have baffles. The spark plugs also look fine and the motor runs great.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-25-2005, 08:14 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,121
Wiki Edits: 0

Thanks: 25
Thanked 266 Times in 249 Posts
Check for wrong spec PCV also check for oil leaking into intake runners from the bottom side. Common problem if heads/block have been milled excessively. Sometimes leaving the end seals out (use silicone) and using thicker intake gaskets will cure the problem.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-25-2005, 08:25 PM
Registered User
 
Join Date: Aug 2004
Location: Ft. Pierce FL
Age: 27
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thx for the tip bud, so PCV vales do have specs..? i just picked one off the shelf at discount that fit in the valve cover. i know the Machinist only shaved a little off the heads to freshen them up, ill look into it anyway. thx alot
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.