Hemi trans? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-10-2003, 08:32 PM
bad429's Avatar
Member
 
Last photo:
Join Date: Jun 2003
Location: West Virginia
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hemi trans?

I recently bought a 392 hemi. Atatched was this ?????? my grand father says its a section or part of a fluid or hydro drive(semi automatic) what does that mean. Never saw a tranny that was auto AND standard. Has any one used these things. I bought a adapter and bell housing to use a 727 so i dont know what im goig to do with this.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-10-2003, 10:01 PM
willys36@aol.com's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild a Rochester Quadrajet 4MV carbureto...
Last journal entry: How to change auto shift timing on 200R4
Last photo:
Join Date: May 2002
Location: Bakersfield
Posts: 8,387
Wiki Edits: 21

Thanks: 1
Thanked 4 Times in 4 Posts
That was one of Chrysler's early (bad) attempts at an auto tranny. Has no value except for restorers. Put it on ebaY. Some sucker will fork out money for it.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-11-2003, 09:12 AM
Registered User
 
Last wiki edit: Mopar tapered axle rear brake conversion
Last journal entry: What I'm doing now...
Last photo:
Join Date: Jan 2002
Posts: 4,267
Wiki Edits: 49

Thanks: 0
Thanked 4 Times in 4 Posts
If your hemi came with that trans installed I'd double check the ID numbers on the front of the block to make sure it's a 392. I don't think any 392's came from the factory with the fluid drive trans. Only early 331's.

Centerline
http://www.hotrodsandhemis.com
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-11-2003, 09:19 AM
bad429's Avatar
Member
 
Last photo:
Join Date: Jun 2003
Location: West Virginia
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yea the engine is a CE57 the engine is from a imperial but ended up in a earlier new yorker.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-11-2003, 09:24 AM
willys36@aol.com's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild a Rochester Quadrajet 4MV carbureto...
Last journal entry: How to change auto shift timing on 200R4
Last photo:
Join Date: May 2002
Location: Bakersfield
Posts: 8,387
Wiki Edits: 21

Thanks: 1
Thanked 4 Times in 4 Posts
Quote:
Originally posted by Centerline
If your hemi came with that trans installed I'd double check the ID numbers on the front of the block to make sure it's a 392. I don't think any 392's came from the factory with the fluid drive trans. Only early 331's.

Centerline
http://www.hotrodsandhemis.com
Good point. '57 & '58s (only years that 392s came in) came with pushbutton Torqueflites didn't they?

Check the serial number stamped on the front of the block just behind the water pump. Will have a 'CXX' there , the 'XX' being year.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.