Hesitation - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-27-2005, 06:54 PM
1969NovaSS's Avatar
turbo lag......yeeeeehaaaaaaw
 
Last photo:
Join Date: Feb 2005
Location: oxnard,ca
Age: 27
Posts: 684
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 4 Posts
Hesitation

I have a slight problem with my nova. Whenever i give it gas there is a slight hesitation then throws you back. It also happens when i give it gas in park or nuetral(very embarrasing at the cruise nights). its a 350 with rpm intake, edelbrock 750 w/ mech. sec., xe 268cam, and ported 305 heads. Any help would be appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-27-2005, 07:05 PM
NXS's Avatar
NXS NXS is offline
wind & fire = guides to power
 
Last photo:
Join Date: Nov 2004
Location: Oklahoma
Posts: 1,534
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
The carb is big for the cam and CI. a 750 Vac would be better.

The pump shot may correct this...or the power valve. What color cam, what size squirter and what size power valve in addition to the vacuum at idle.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-27-2005, 10:15 PM
1969NovaSS's Avatar
turbo lag......yeeeeehaaaaaaw
 
Last photo:
Join Date: Feb 2005
Location: oxnard,ca
Age: 27
Posts: 684
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 4 Posts
Hesitation

It never did this before and ive had this engine since january. I put my friends 650 carter on a couple days ago and my friends 650 speed demon befor i put it on his car and it did the same thing. It only really does it once i floor it or when its warmed up and in nuetral or park.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-27-2005, 11:03 PM
killerformula's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Carburetor
Last journal entry: Clean up
Last photo:
Join Date: Oct 2003
Location: Northeast
Age: 34
Posts: 3,485
Wiki Edits: 3

Thanks: 13
Thanked 27 Times in 18 Posts
look for pump shot, vacuum leak or a squirter size that's too large.

K
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-30-2005, 11:07 AM
Member
 
Join Date: Jul 2005
Location: Montana
Posts: 98
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Double check your vacuum advance--bad pot or wrong signal?? Is your mechanical advance stuck?? Seems to me if you've had 3 different carbs on it, you are looking in the wrong place for your problem. The next best place for a stumble is the advance systems--
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 08-01-2005, 09:11 AM
Technical Support Barry Grant
 
Last photo:
Join Date: Jul 2003
Location: Dahlonega, GA
Posts: 1,503
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 1969NovaSS
It never did this before and ive had this engine since january. I put my friends 650 carter on a couple days ago and my friends 650 speed demon befor i put it on his car and it did the same thing. It only really does it once i floor it or when its warmed up and in nuetral or park.

If it doesn't do it when the engine is colder, you may be too rich already.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation on 350 trenchdog73 Engine 16 04-11-2007 11:03 AM
327 hesitation on acceleration super_silent Engine 8 01-03-2005 07:54 PM
Holley hesitation harrassment Neal Green Engine 12 11-25-2004 11:36 PM
chevy 350 hesitation BICHN69 Engine 2 06-25-2004 10:56 PM
hesitation at cruise speed 55belairht Engine 8 08-16-2002 02:58 PM


All times are GMT -6. The time now is 09:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.