Hey DocVette...ECM question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-20-2005, 05:42 PM
Kevin45's Avatar
Just one of the guys
 

Last journal entry: Garage Toys
Last photo:
Join Date: Jul 2002
Location: Urbana, Ohio
Age: 57
Posts: 3,058
Wiki Edits: 0

Thanks: 1
Thanked 15 Times in 15 Posts
Hey DocVette...ECM question

Docvette....I am having a problem I hope you can give me an answer to. It concerns the ECM, PROM, and a 4.3 to a 350 engine swap. We did this in my '93 Chevy truck. I have been told a multitude of things so I am now asking you. We retained the factory harness although we had to change a couple of connectors due to the engine having a Holley throttle body. So we had to swap connectors for the injectors that came with it. No problem there. The engine is in and everything is wired except for an EGR that I am waiting for an EGR relocator for. We got it fired but it ran terrible. I am assuming from the 4.3 computer and PROM that was still in it. Looking at a few other sites I found out that the ECM for the '93 is only made for that year and it runs either a V8 or a V6 but the PROM needs to be swapped for a V8 PROM. I failed to mention the truck has the 4L60E tranny that I am keeping in it. My question is...can I go to the wrecking yard and get a different PROM, or is there a couple of years that I can get one from, or does it have to be '93 specific. I did find a place that can burn one for me for less than 2 bills but I hate to spend the money yet, if I am having other problems. I am hoping that I can pull a V8 PROM from another vehicle to get mine running then work out some bugs that way. So anyways....ANY INPUT???????? Thanks Doc and whoever else has input.

Kevin

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-20-2005, 07:22 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Memcal/calpack

Doc here,

Kevin,

First I'm not a programmer by any means..I'm a PARTS changer where this is involved.. (except when it comes to my own stuff...then I'll dig into the motherboard..) But what I do know I will share with you...

First (and I haven't a real clue if this will work or not...It does in Vettes with new Correct<--read.. memcal apps..)Try Starting / Stopping the Truck up to 25 times to program in new values...Although the standards by which they operate are usually burned in...prior reference data can be discarded and new reference data fed in..by inducing up to 25 Ignition cycles..It's possible it may work..but couldn't tell you for sure...but easy enough to try..

However, What I think your fighting here is timing and sync setup (by flash/burn in on the memcal) For a 6 cyl on an 8 engine...In theory, It should have backfired a lot in addition to running rough...unless that has a calpack (limp home feature) in it and that was what you were running on...

What I do Know is...1993 truck was the new memcal..should be a 27c512 ..28 pin DIP chip...prior was the 2732 Memcal 24 pin dip..(1987-91) So in answer to that question..yes it must be 93 (or up specific..)the other memcal won't even plug into the computer..The new Memcal also allowed for the electronics on the transmission..

What I'd try First, is find a 93 (or up specific) Truck at the bone yard with a 350 original application, and same set up as you have now...pop the chip out of it..be sure it's a 28 pinner..on both your computer and the donor chip..

Insert that one in your computer, and fire it up..If it runs crappy , but better than before try the Ign cycle thing and see if the new engine values won't upload..(they should as new reference data)

Not sure what they are getting for bone yard chips in your area, around here they are about $10 to $40 bucks...

Who REALLY know his stuff about this is Ghetto Jett or Siggy...can't remember which..., he (I think, read a book) or Took a class...AND bought a programmer...and if I followed his posts correctly has had good success with programing chips..you may want to PM him..Worst case scenario, he may be able to Burn a chip for your application..(probably won't charge ya 200 bills for it either!)

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations

Last edited by docvette; 06-21-2005 at 05:13 AM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-23-2005, 06:49 PM
Kevin45's Avatar
Just one of the guys
 

Last journal entry: Garage Toys
Last photo:
Join Date: Jul 2002
Location: Urbana, Ohio
Age: 57
Posts: 3,058
Wiki Edits: 0

Thanks: 1
Thanked 15 Times in 15 Posts
Doc...just to let you know...I picked up a computer out of a '94 with a 350. Plugged it in, hit the key and she fired right up and idled. But I still have a few things to get done to the engine to work ouut the bugs. EGR valve, some vacuum routing, timing. But mainly I want to say thanks for the info.

Kevin
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Points question (Hey Doc!) garretthes Engine 14 09-26-2004 09:13 PM
Water Pump Question Kaylah Engine 11 08-22-2003 09:35 PM
hey, i have a question Thuggishruggish3000 Body - Exterior 3 07-31-2003 06:23 PM
Chevy ECM ALDL question mark280zx Electrical 1 07-29-2003 09:58 PM


All times are GMT -6. The time now is 07:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.