hey i have backfiring issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-12-2013, 06:17 PM
Registered User
 
Join Date: May 2013
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hey i have backfiring issues

I have a 76 firebird with a 455 rocket and it backfires heavily and i believe it is fron the carb but there is no soot or anything at all, when i put the gas peddle down.it loses power and.backfires

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-12-2013, 07:43 PM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 56
Posts: 7,995
Wiki Edits: 0

Thanks: 317
Thanked 776 Times in 743 Posts
check your timing. check the plugs & wires. is the engine stock or hi performance? did this just start happening all of a sudden?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-12-2013, 08:18 PM
NEW INTERIORS's Avatar
Believe in yourself !!!!!!
 

Last journal entry: 41 WILLYS FRAME
Last photo:
Join Date: Jul 2007
Location: In My Shop..
Age: 49
Posts: 10,094
Wiki Edits: 0

Thanks: 1,247
Thanked 549 Times in 407 Posts
If all else check's out fine,, Could be a rounded lobe on the cam..
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-12-2013, 08:39 PM
Registered User
 
Last photo:
Join Date: Nov 2012
Location: Cincinnati, Ohio
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Check timing and also where you have the vacuum for advance connected to the carb. If you are running a HEI distributor, try connecting the vacuum line to the ported connection rather than the port below the throttle plates. While you may have correct timing readings with the vacuum line disconnected, see how much you have when it is connected at idle. If the vacuum advance is not limited, you could be adding a lot of timing at idle that you don't see unless you check for it with a dial back light. I have seen a vacuum can on an HEI that had 22 1/2 degrees that it added at idle when connected to the full vacuum port on the carb. It will cause the popping and backfiring up through the carb when you try to come off idle.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-12-2013, 11:29 PM
Registered User
 
Join Date: May 2013
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hm i will post a vide and yes it just started happenning car was faster then a bat out of hell before this and i believe it is performabce maybe
Reply With Quote Quick reply to this message

Tags
back firing

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backfiring issues Linez35 Engine 3 08-16-2010 11:03 PM
backfiring 79chevy4x4 Engine 32 01-20-2007 03:37 PM
backfiring 1980Impala Engine 5 03-15-2004 05:34 PM
backfiring zipfactor Engine 13 11-09-2003 09:28 PM
backfiring 55relic Engine 10 06-07-2003 07:41 PM


All times are GMT -6. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.