High Idle on MFI - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-16-2006, 08:01 PM
bluesman123's Avatar
Member
 
Last photo:
Join Date: Nov 2002
Location: Bay Area, California
Age: 68
Posts: 593
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
High Idle on MFI

I have a hi idle on an MFI system. This is an L31 in a Sonoma (350 Vortec with the MFI system), basically stock with the exception of a cool air induction and more open exhaust. I have checked the linkage and it seems free moving. There are no codes being thrown. If I hold on the brake the idle slowly comes down to where it is supposed to be.

Any ideas are GREATLY appreciated!!

Dave

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-16-2006, 08:34 PM
67 Deuce 4 Me's Avatar
Bowtie or Die!
 
Last photo:
Join Date: Dec 2004
Location: TN
Age: 43
Posts: 637
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Without scanning the data from the pcm, it can be difficult to diagnose that problem. Most likely problem is a vacuum leak. A bad IAC valve can cause high idle. A bad pcm can cause it as well. A bad TPS can cause it. But those things usually WILL set a code. Im not telling you to go throw a bunch of parts on it I just pointing out possibilities. Is it Mass air flow system?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-16-2006, 09:02 PM
bluesman123's Avatar
Member
 
Last photo:
Join Date: Nov 2002
Location: Bay Area, California
Age: 68
Posts: 593
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yeah I'm with you about throwing parts at it. The thing that has me puzzled is the lack of a code. I was thinking about the IAC, but hate to just throw another one in there. I will check for vac leaks and see if I come up with anything.

dave
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle and dies when put into gear hotrodtodd Engine 5 03-23-2012 06:21 PM
Distributor Tuning and Theory - Part 1 Rick WI Engine 35 04-26-2011 12:38 AM
High Idle Slant3 Engine 4 08-30-2004 12:37 AM
sbc 350 miss under idle Walker Engine 2 07-29-2003 09:02 PM
Q-jet high idle COCHEV Engine 6 06-29-2003 05:04 PM


All times are GMT -6. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.