Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Hitting Hard When Shifting into Drive at Idle
View Single Post
  #10 (permalink)  
Old 08-07-2009, 05:19 AM
My68Vette's Avatar
My68Vette My68Vette is offline
Registered User
 
Last photo:
Join Date: May 2009
Location: Michigan
Posts: 139
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ericnova72
Have you done anything to tune the carb beyond just turning the idle speed and mixture screws??
I also did some tuning with the secondary throttle plates to cure the off-idle stumble.. They are now open slightly, which cured that issue.. I tried a bunch of different configurations between the 4 corner idle mixture screws, opening of the secondary throttle plates and the idle eaze screw in the center and the setting I have now not only obtained the highest vacuum reading but also gave me the best idle at the lowest RPM.. I know I dont have any vacuum leaks and even went as far as unplugging all vacuum lines to the carb and then plugging the ports to see if the vaccum would increase and it didnt.. I also sprayed around the carb and intake.. My Vacuum reading is 8hg at idle with a cam profile that has 260 degreees @ .050.. I farted around with it again last night and managed to get a good idle at 1000 rpm but it still seems to slam hard when I put it in Drive. I turned the vacuum module screw 1 full revolution but it didnt change anything.. By the way, I have a Might Demon carb..
Reply With Quote