Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   holley 1850-1 3146 2000 rpm idle (http://www.hotrodders.com/forum/holley-1850-1-3146-2000-rpm-idle-227921.html)

caleb1563 01-03-2013 07:48 PM

holley 1850-1 3146 2000 rpm idle
 
It was fine other then my secondarys didnt work i changed the diaphragm now it idles a 2000 ive checked the screws and the pump travel and the adjustment screws im outa ideas

cobalt327 01-03-2013 11:39 PM

There are several different secondary diaphragms that have different length stems. The wrong one can tip the secondaries open some, allowing in too much air. This will be like a big vacuum leak and can cause the idle to be too high.

Be sure the diaphragm is holding vacuum. If it isn't sealing the two halves of the vacuum chamber, you'll have a vacuum leak.

Be sure the small cork gasket is in place between the vacuum chamber and main body. Should use a new one, they get compressed during use and sometimes won't seal so good if reused. I have taken to using a small rubber O-ring for this, but it takes an uncommon size. So if you were to try this be sure the O-ring is only a little thicker than a new cork seal.

Check for carb-to-intake gasket leak, vacuum leaks in general.

If you have a choke, be sure the fast idle cam isn't hanging up. Be sure the gasket under the carb isn't holding the throttle blades open.

caleb1563 01-04-2013 11:31 AM

I checked i have the right diaphragm i check the gasket its good i used an oring but it still does it i believe my primarys are closeing all the way im going to check further if there not what could cause it

oldbogie 01-04-2013 12:54 PM

Quote:

Originally Posted by caleb1563 (Post 1630518)
I checked i have the right diaphragm i check the gasket its good i used an oring but it still does it i believe my primarys are closeing all the way im going to check further if there not what could cause it

Check the secondaries very carefully to be sure they are fully closed, it doesn't take much missalignment of the throttle plates for them to bind in their bores before they are truly shut. Also, check the seating lever adjustment screw that comes up from below the throttle shaft boss to be sure it's not cracking the secondaries a bit. It doesn't take much to really raise the idle, the smallest gap is plenty to cause this.

Also, check the seating on the manifold, if you overtighten the mounting nuts, the cast ears bend down which bows the throttle body allowing air to get between the gasket, manifold and throttle body. If you bent these there are two solutions one is to mill the bottom flat the other is to replace the throttle body as it is a casting so trying to bend the mounting ears backward if they are bent usually breaks them.

Bogie


All times are GMT -6. The time now is 09:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.