holley 1850-1 3146 2000 rpm idle - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-03-2013, 07:48 PM
Registered User
 
Last photo:
Join Date: Feb 2009
Location: littleton
Posts: 41
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
holley 1850-1 3146 2000 rpm idle

It was fine other then my secondarys didnt work i changed the diaphragm now it idles a 2000 ive checked the screws and the pump travel and the adjustment screws im outa ideas

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-03-2013, 11:39 PM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 597 Times in 546 Posts
There are several different secondary diaphragms that have different length stems. The wrong one can tip the secondaries open some, allowing in too much air. This will be like a big vacuum leak and can cause the idle to be too high.

Be sure the diaphragm is holding vacuum. If it isn't sealing the two halves of the vacuum chamber, you'll have a vacuum leak.

Be sure the small cork gasket is in place between the vacuum chamber and main body. Should use a new one, they get compressed during use and sometimes won't seal so good if reused. I have taken to using a small rubber O-ring for this, but it takes an uncommon size. So if you were to try this be sure the O-ring is only a little thicker than a new cork seal.

Check for carb-to-intake gasket leak, vacuum leaks in general.

If you have a choke, be sure the fast idle cam isn't hanging up. Be sure the gasket under the carb isn't holding the throttle blades open.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-04-2013, 11:31 AM
Registered User
 
Last photo:
Join Date: Feb 2009
Location: littleton
Posts: 41
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I checked i have the right diaphragm i check the gasket its good i used an oring but it still does it i believe my primarys are closeing all the way im going to check further if there not what could cause it
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-04-2013, 12:54 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,814
Wiki Edits: 0

Thanks: 4
Thanked 447 Times in 382 Posts
Quote:
Originally Posted by caleb1563 View Post
I checked i have the right diaphragm i check the gasket its good i used an oring but it still does it i believe my primarys are closeing all the way im going to check further if there not what could cause it
Check the secondaries very carefully to be sure they are fully closed, it doesn't take much missalignment of the throttle plates for them to bind in their bores before they are truly shut. Also, check the seating lever adjustment screw that comes up from below the throttle shaft boss to be sure it's not cracking the secondaries a bit. It doesn't take much to really raise the idle, the smallest gap is plenty to cause this.

Also, check the seating on the manifold, if you overtighten the mounting nuts, the cast ears bend down which bows the throttle body allowing air to get between the gasket, manifold and throttle body. If you bent these there are two solutions one is to mill the bottom flat the other is to replace the throttle body as it is a casting so trying to bend the mounting ears backward if they are bent usually breaks them.

Bogie
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
holly 1850-2 idle adjustments sbcvtc Engine 2 03-08-2011 07:55 AM
Holley 1850?? Chevy21 Engine 5 07-24-2005 10:15 AM
Idle in Park is 1,800 RPM....Idle in gear in 900 RPM...Way too High. white66coupe Engine 11 09-10-2004 11:49 AM
Holley 1850 V8 Datsun Engine 8 08-10-2004 02:37 PM
1850-3 Holley adjustments 1980Impala Engine 5 06-02-2004 02:31 AM


All times are GMT -6. The time now is 05:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.