Holley acting up - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-12-2008, 12:39 AM
Registered User
 
Last photo:
Join Date: Apr 2008
Location: Benito MB canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Holley acting up

So i got this 650 double pump at an auction, rebuilt it and put it on my car. I set it up and it ran perfect but then i ran out of gas so i got some gas a few days later fired it up and it ran but no idle as if the idle circuts were plug, so i took it apart cleaned it and she ran again, but i ran out of gas. Again i got some gs a few days later went to fire it and the same thing runs but no idle, i pulled the set screw blew air through but still nothing. I'll clean it again tommorrow but why does this keep on happening!!? Thanks, Jake

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-12-2008, 01:05 AM
327NUT's Avatar
Registered User
 
Last photo:
Join Date: Dec 2004
Location: So. Utah
Age: 68
Posts: 3,292
Wiki Edits: 0

Thanks: 0
Thanked 91 Times in 82 Posts
Sorry but if I was a real smart a-- I could have a lot of fun with this. Does running out of gas all the time tell you anything about a DP Holley?? They are not very practical on the street, we used to call them "a semi-controlled leak". With the price of gas that would be the last carb I would be running. By the way, don't let your tank run dry, you're probably sucking up some debris off the bottom and depending on how good your fuel filter is it's most likely getting into your idle circuits.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-12-2008, 06:31 AM
Member
 
Last photo:
Join Date: Feb 2003
Posts: 642
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It probably would not be a bad idea to umm put an inline filter in it ehh. Anything old thats been sitting i always run 2 inline filters (clear) one prior to the fuel pump and one after it.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-12-2008, 06:35 AM
dawg's Avatar
NAVY VETERAN
 
Last photo:
Join Date: Aug 2004
Location: Colebrook Connecticut
Age: 55
Posts: 912
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 5 Posts
cmon now
DP carbs are as dependable as the person that tunes them.
never had an issue with a controlled leak.
your problem is crap in your fuel lines and tank.
Most likely rust particles.
quick fix is to drain tank and seal the tank with a tank sealer.
get it here:
http://www.eastwoodco.com/jump.jsp?i...emType=PRODUCT
also use some metal wash:
http://www.eastwoodco.com/jump.jsp?i...emType=PRODUCT
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-12-2008, 08:50 AM
Registered User
 
Last photo:
Join Date: Apr 2008
Location: Benito MB canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The tanks been cleaned and i have a clear filter inline before the pump, the reason why i run out of gas is cause i run premium and i have to drive 40 miles to get it so i usually just fill a jerry can for the weekend. When running right i really like this carb performs, its much better than the 670 street avenger i had on it IMO.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-12-2008, 02:55 PM
cool rockin daddy's Avatar
1.21 giga-watts???!!!!
 
Join Date: Aug 2003
Location: wherever cool cars are
Posts: 1,535
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
Fill the tank up!!!!!!
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-12-2008, 05:26 PM
Registered User
 
Last photo:
Join Date: Apr 2008
Location: Benito MB canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The tanks is full Well i took the front metering block off and cleaned her up blew out all passage ways in it and the main body but still nothing. I tried changing the metering screws as well but its a no go. Is there any metering cicuits in the secondaries? It ran fine 3 days ago what is goin on!!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
That lousy Holley carb cool rockin daddy Engine 30 02-29-2008 02:01 PM
edelbrock vs. holley carb Super Chevy Engine 43 01-21-2006 09:55 PM
Holley throttle body Kevin45 Engine 1 06-10-2005 11:46 AM
Carb comparison Demon vs Holley DTL504 Engine 12 12-29-2004 02:53 PM
MSD offroad-6, MSD 8366 Distributor, Holley 950 ECU izord Electrical 0 09-06-2004 02:16 PM


All times are GMT -6. The time now is 11:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.