Holley pro-jection 2D prob, I think? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-18-2010, 02:09 PM
Registered User
 
Join Date: Sep 2010
Location: uk
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Holley pro-jection 2D prob, I think?

Hi All
I have a small problem with the idle speed of my 5.7 land rover, it has a Chevy 5.7 fitted in place of the old 3.9 lump, but once warmed up it idles at about 1200 rpm unless i blip the throttle then it goes back down to 800rpm, this is not just when its warmed up from cold it happens every time i accelerate. When braking or de accelerating i have to blip the throttle every time to drop the rpm so that it slows down as it should do. i have tried and fitted several throttle return springs, but it seems to be a soliniod fitted to the side of the injection housing (looks like a carb housing) but don't know how or what i have to do to fix it anyone got any ideas. based in the UK in East Anglia so if anyone knows any Chevy/Holley pro-jection specialist in my area cant find any looking in the normal places. Just for info i didn't build the discovery and i think this problem has been with it since it was converted. Is the Holly injection not up to the job.
kind regards
Ray
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-19-2010, 02:42 PM
vicrod's Avatar
life is a ride
 

Last journal entry: LED tail lights
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 71
Posts: 1,236
Wiki Edits: 0

Thanks: 0
Thanked 45 Times in 41 Posts
Try to get the complete manual available from Holley via internet (google).
Go to a repair shop that works on fuel injection systems which in the US is any car less than 25 years old.
The Holley setup is simple compared to modern FI systems.
Possibly the throttle linkage is hanging up.
Also, try to disconnect the wire going to the fast idle speed solenoid. The solenoid could be faulty. You will lose the fast idle feature but maybe you could adjust the idle speed to work OK.

vicrod
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-20-2010, 03:05 PM
Registered User
 
Join Date: Sep 2010
Location: uk
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks

Thanks vicrod will have a phone round tomorow to see who will take a look for me may try disconecting it first to see if it will run without it. will look to down load the complete manual from the web site.
Thanks once again
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to stroke a 400 more than it already is? stonedchihuahua Hotrodding Basics 18 11-10-2012 08:27 AM
Holley HP or pro form DougMN Engine 2 05-07-2007 10:35 AM
edelbrock pro flo/ holley commander htwheelz67 Engine 6 04-05-2004 07:53 AM
pro jection cleaco Engine 1 03-14-2004 10:29 AM


All times are GMT -6. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.