Holly 4150 question. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-29-2005, 07:29 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Holly 4150 question.

Just bought a 4150 doublepumper from a buddy. He hasn't used it in a while (great condition) and I have a question about the dual feed line.

Is it supposed to have a plastic piece inside the line to the secondary bowl?

The reason I am asking is because fuel was pouring out of the vent tube at the top when I tried to start it (letting battery charge ATM) I am new to the whole Holly thing. I have lowered the level, and it came over the front now, so I lowered that one. What's up with that?

I just want to get it started! LOL

Thanks for the help,
Tom

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-29-2005, 08:18 PM
lluciano77's Avatar
Short changed on common sense
 
Last photo:
Join Date: Jun 2003
Location: california
Age: 37
Posts: 3,548
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Holleys originally came with an inline filter before the bowls. It was't made of platic though.

It sounds like there is something either stuck in the needle and seat, the floats need to be adjusted, or the gasket is missing on the needle and seat.

I suggest you read up as much as possible if you are going to run a Holley. They aren't just run and go carbs. It takes years to be able to tune them well.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-29-2005, 08:50 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
That's what I was hoping. It looks like there are NO gaskets except on the bottom below the main body. I have gotten it to run finally. (WOOHOO) but I have to hold it almost 1/3-1/2 open just to get it to idle. By the way...I had 8" of vacuum at idle when I was running an Edelbrock on it. I know I'll need a new power valve, but will teh gaskets make that much difference?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-29-2005, 10:18 PM
lluciano77's Avatar
Short changed on common sense
 
Last photo:
Join Date: Jun 2003
Location: california
Age: 37
Posts: 3,548
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I ended up going to the Holley 4010. It only has one main gasket that is above fuel level. Less chance for leaks.

With any Holley, a rebuild kit is almost always necessary if the carb has been sitting for a while. Holleys are tempermental. Especially when small particles in the fuel bowl get stuck in the needle and seat.

I think your needle and seat are bad. Rebuild it, clean it, and try running it again. If it is still having troubles well go from there.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-29-2005, 10:55 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
I appreciate the help. After getting it to run, I decided to check hood clearance (91 camaro) and it will NOT fit without a hood scoop (or no filter...no way). I will still take it off and do some cleaning to it, but my project had just been put on hold for a while.

Seems like it is becoming more of a PITA to do any good mods to this car, therfore I'll be in the market for some 60's/70's Chevy Muscle pretty soon....I know it'll fit then!

Again...thanks for all the help!
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-29-2005, 11:09 PM
Member
 
Join Date: Dec 2004
Location: Madison, WI
Posts: 1,885
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
It won't fit with a drop base air cleaner?
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-30-2005, 01:13 AM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Nope...The drop base I have is 2 inches. It was on my edelbrock which barely fit.

Whenever I shut the hood, the Holly's choke blade barely hits it. No room. I might be having a guy buy the body in a few weeks anyway. He's been looking for a few months and just happened to come across mine today.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-30-2005, 07:43 AM
Member
 
Join Date: Dec 2004
Location: Madison, WI
Posts: 1,885
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
That sucks
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-30-2005, 07:20 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Well...today I went and pulled all sparkplugs, and turned the car over to clean out the cylinders....SPLASH!!! it went from the right side.

Decided to pull the carb, and I noticed that it leaks from a little hole. (Also realized that I never tightened the front right carb bolt down. Doh!! )

If looking at the bottom, w/ the front blow facing up, there is a bolt between and above the mains. Just to the right of that is a hole and it was leaking pretty bad. It almost looks like there is a checkball in there.

Is this the power valve protection?

This also explains why my cylinders filled with gas.

.....and so begins my journey....LMAO
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-31-2005, 01:03 AM
lluciano77's Avatar
Short changed on common sense
 
Last photo:
Join Date: Jun 2003
Location: california
Age: 37
Posts: 3,548
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It sounds like you are missing the powervalve gasket. Either that or the one you have is bad.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 07-31-2005, 01:51 AM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
funny you mention that....i took the whole thing apart tonight...the gasket was not on straight!....plus the checkball was stuck. loosened it up, and fixed the gasket...

No leaks now, but i had to drain my oil because it had gasoline in it...flushed the oil system, and now just need new sparkplugs to replace the broken ones...lol my o2 sensor was in the way of #5 plug and i ended iup breaking both trying to remove them.

must say...the holley is simple, yet very complicated at the same time...glad i bought it!
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 07-31-2005, 06:30 PM
Member
 
Last photo:
Join Date: Apr 2004
Location: California
Age: 37
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
SHE LIVES!!!!

Doublechecked everything. Changed the oil. Replaced the sparkplugs....turned the key.

Now I just need a 4.5 powervalve. This would be correct for 7" of vacuum at idle, right?

Thanks for all the help guys. Between this post and the other 4150 posts, I have definately been taught a lesson in humility.

Tom
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 07-31-2005, 07:31 PM
lluciano77's Avatar
Short changed on common sense
 
Last photo:
Join Date: Jun 2003
Location: california
Age: 37
Posts: 3,548
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Either a 3.5 or a 4.5. You will have to see which one it likes better. You want the powervalve to open safely above idle. You also want it to come in early enough to add it's extra enrichment.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holley 4150 / timing question 70bird Engine 6 04-01-2005 07:19 AM
Holley 4150 question OldBucsFan Engine 1 03-03-2005 08:40 PM
Holly 3310 Question solidaxel Engine 5 02-26-2005 01:57 PM
holly carb float question impala65 Engine 3 03-30-2004 09:44 AM
Holly 4150 question OldBucsFan Engine 11 08-04-2003 09:59 AM


All times are GMT -6. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.