Home plating question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-19-2010, 04:03 PM
Registered User
 
Last photo:
Join Date: Jul 2009
Location: San Antonio
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Home plating question

Guys,

I just started plating my hardware with the Caswell Copy Cad/Zn plating kit. It seems to be working OK, but I'm getting a dull grey finish (like galvanized)when I run the Copy Cad, and when I add the brightener (for a clear Zn finish) it looks lighter, but not like zinc, more like light grey/whitish, almost like Cad. Does anyone use this system and have any experience with this? Any advice would be appreciated.

ML

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-19-2010, 04:20 PM
Joe G's Avatar
Registered user
 
Last photo:
Join Date: Nov 2008
Location: St. Paul, MN
Age: 40
Posts: 599
Wiki Edits: 0

Thanks: 80
Thanked 38 Times in 37 Posts
To get the dull grey fuzz off the plating, you can use very fine steel wool or metal polish, or a vibratory polisher.

I had an Eastwood zinc plating set for a while; never was quite satisfied with the final result. Sure it was zinc, but I could never get the plating as thick as a commercial plater, not even close. The plating would come out so thin that you could scratch it off with your fingernail. I monkeyed with different power supplies and immersion times, but I finally gave up on the Eastwood set...hope you have better results with yours.

There is a local plater near me that will plate up to 60 pieces for $30, clear, yellow, or black zinc. They do a better job than I could do, and I can get 200-300 parts done in 2-3 days.


Hope this helps, and good luck...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-19-2010, 04:39 PM
Registered User
 
Last photo:
Join Date: Jul 2009
Location: San Antonio
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I'm using the Caswell set, not the eastwood. I went whole hog and got one of their $300 power units so I'm into this entire setup for $600-$700. I am starting to think I should have gone with a professional plater, as I have done in the past, but I was always realizing that I forgot to send that one last thing and I would be stuck. I may send out the bulk of my stuff to the pros and use this set for those occassional left over pieces, but that still means that I have to get to work first. Anyone with any experience with the Caswell setup?

ML
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-20-2010, 07:29 AM
cboy's Avatar
Member
 

Last journal entry: Finished
Last photo:
Join Date: Jan 2004
Location: Atwater, CA
Age: 69
Posts: 3,918
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
No experience or tips to pass along but keep us posted on your progress and experimentation...with pictures if at all possible.

I think Willys36 has used the Caswell system with some success. You might want to PM him and ask your question directly.
__________________
Always learning...and sharing what I've learned. The Scratch-Built Hot Rod.
Reply With Quote Quick reply to this message

Recent Garage - Tools posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker 73monte Engine 11 05-07-2014 08:08 AM
supercharger.... 73monte Engine 16 07-24-2010 10:27 AM
Fuel System question Ratoflic Engine 6 01-23-2010 12:10 PM
Ignotion Set-ups Native Gearhead Engine 8 11-29-2003 01:20 PM
Hi All I just Joined, Questions Re:454 rebuild Gay-Shark Engine 8 11-29-2003 10:25 AM


All times are GMT -6. The time now is 08:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.