Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   hot power steering pump, (http://www.hotrodders.com/forum/hot-power-steering-pump-145808.html)

steve t 09-28-2008 03:13 PM

hot power steering pump,
 
i installed new power steering pump on 61 impala,new p s system,ram and valve.pump runs real hot in no time ,when you start engine,idle like 1 min, what is wrong, help :confused:

carsavvycook 09-28-2008 04:06 PM

Do you have Headers on it, and how close is the exhaust routed to it?

steve t 09-28-2008 04:45 PM

thanks, but it not the headers

carsavvycook 09-28-2008 06:32 PM

OK, You say it get's 'hot after 1 minute of running'. Does the fluid get 'foamy'? Making you think it gets hot, or is it too hot to touch?

What "type" of steering system do you have? I take it, that you have a 'pump, and rack' assembly. What is it out of?

Does it have a pump, control valve, and power cylinder? Early GM, and Ford passenger cars used this system. These systems are also easy to adapt into other older cars. Been there, and done that.

This could be as 'simple' as the P/S pump pulley spinning backwards, or a defective pump. :thumbup:

steve t 10-07-2008 05:36 PM

i fixed the problem, it was a air lock in system,bleed it out


All times are GMT -6. The time now is 08:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.