Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Body - Exterior (http://www.hotrodders.com/forum/body-exterior/)
-   -   Hot Rod Flatz paint problem (http://www.hotrodders.com/forum/hot-rod-flatz-paint-problem-115908.html)

Bob 1743 05-12-2007 02:22 PM

Hot Rod Flatz paint problem
 
I applied 3 coats of Hot Rod Flatz, Flat Black, and found that it dried with some spots that remained glossy. Did not flatten out properly.
The paint was well mixed with the correct proportions of paint/hardner/reducer. I made all attempts to apply at a uniform distance and right angle. I 'm lost for a cure.
I have been told that a light sanding with a wet scuff pad will even things out and look OK. Has anyone ever tried this remedy?
Any help would be greatly appreciated,
Bob

Rambo_The_Dog 05-14-2007 05:20 AM

Quote:

Originally Posted by Bob 1743
I applied 3 coats of Hot Rod Flatz, Flat Black, and found that it dried with some spots that remained glossy. Did not flatten out properly.
The paint was well mixed with the correct proportions of paint/hardner/reducer. I made all attempts to apply at a uniform distance and right angle. I 'm lost for a cure.
I have been told that a light sanding with a wet scuff pad will even things out and look OK. Has anyone ever tried this remedy?
Any help would be greatly appreciated,
Bob

Did you apply a full coat sealer before applying the topcoat?

I've seen this happen with differing substrate materials before...


All times are GMT -6. The time now is 11:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.