hot side, 350 tpi engine runs hot on one bank? - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 10-27-2002, 05:39 AM
Registered User
 
Join Date: Oct 2002
Location: Watford, England
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

JAMES dont be silly, The fuel comes from a high pressure pump to the fuel rail which distributes the fuel to all injectors, the fuel rail then returns any unwanted fuel back to the tank, you cannot and must not block up any returns! the fuel rail and injectors have all been ultrasonic cleaned and tested for flow and pattern before the motor was put together to make sure that there were no problems with them, the fuel rail has a pressure gauge on it to monitor the pressure and its firm at 38psi which is on spec. I build once properly not twice badly (but thats a dream if it works first time). As far as a air leak is conceren i dont think there are any as it is all new but its worth trying with some oil spray. As for tight valves the liffters are hyd and i have checked them all, the other bank by the way did have a sticking valve after the rebuild but once it was re adjusted the problem stopped, i checked all compressions after and they are all fine.

[ October 27, 2002: Message edited by: Ellisb ]</p>

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 10-27-2002, 07:28 AM
Member
 
Join Date: Oct 2002
Location: Redwood Valley
Posts: 31
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

That's the first time you mentioned fuel pressure and yes 38 psi sounds good. Pinching off the return line would have only been a diagnostic tool and not permanent.

Another thing to keep in mind, just because something is new doesn't make it good.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.