Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   How to make right side turn signals and brake lights work on 75 TA (http://www.hotrodders.com/forum/how-make-right-side-turn-signals-brake-lights-work-75-a-222631.html)

walt03 08-06-2012 11:23 PM

How to make right side turn signals and brake lights work on 75 TA
 
This 75 Trans Am has the left side front and rear turn signals working.
On the passenger side, the front works but the back doesn't and all bulbs check out.
Also, the passenger side, the brake lights don't work if this is part of the same problem.

Switched around fLASHER RELAYS from AND STILL THE SAME THING. Relays don't make any difference.
I'm scratching my head on where to go next.
Can anyone help?
Thanks
Walt

EOD Guy 08-07-2012 05:08 AM

Sounds like bad grounds...... run a temp ground with a piece of jumper wire from the body of the light socket to a clean bare spot on the frame etc..... if it works well just a little cleaning etc...

dogwater 08-07-2012 07:27 AM

Do the temp. Ground wire first ,thats easy,if that doesnt help use a vlotage meter,be sure to set it to DC and start checking for voltage.Behind the horn botton inside the colum theirs a white plastic thing that the turn siganl lever switchs back an forth,it been a long time since Ive messed around with one but it might have contacts on it,they may be broke off or not making contact.


All times are GMT -6. The time now is 11:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.