how much timing at idle for this cam? - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 10-07-2012, 07:15 PM
F-BIRD'88's Avatar
Yada Yada Yada
 
Last photo:
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 9,153
Wiki Edits: 0

Thanks: 5
Thanked 380 Times in 374 Posts
You will be much further ahead by concentrating less on what giuy over on this that board is doing or BSing about and work on your own car. There is lots of BS on the boards Especially when it comes to dynos and HP. NO buddy makes 1000 HP with 882 heads. What is it 60psi of boost? and 3 bottle of nitrous oxide?
All you will do is create boost (back pressure) as the air cannot get in or out of the motor with 882 heads on it.
They flow like **** even when fully ported. 100hp less than a camel back or stock vortec or simple entry level perf head on a simple N/A street motor. Give your head a shake. All the blower boost in the world won;t fix a bad cylinder head.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 10-07-2012, 08:01 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 976
Wiki Edits: 0

Thanks: 12
Thanked 33 Times in 30 Posts
funny u say that since the car went 11.83@ 132 with a ton of tire spin @ 15 psi witht he summit cam and 882 heads
Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 10-08-2012, 03:48 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 976
Wiki Edits: 0

Thanks: 12
Thanked 33 Times in 30 Posts
got the laptop out and bumped idle timing back to 30* it idles better now , have to change my iac settings though as this cam drives it a lil crazy trying to hold a steady idle.

right now its setup to hold a 850rpm idle , im going to change it so its only active on cold starts once the motor reaches 140* ill have the iac fully close and ill set idle speed witht he adjusting screw on the tb

twin turbo iroc - YouTube
"> twin turbo iroc - YouTube
" type="application/x-shockwave-flash" width="425" height="350">
Reply With Quote Quick reply to this message
  #19 (permalink)  
Old 10-12-2012, 06:36 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 976
Wiki Edits: 0

Thanks: 12
Thanked 33 Times in 30 Posts
well the ole butt dyno says not to bad
spoolup is a tad bit lazy in first gear, but thats actually a good thing in my case, before this thing woudl blow the rear tires right off , now it has a chance to grab some traction at lower rpms

its still pulling pretty damn hard once its in full boost

old cam ='s full boost at 2,800
new cam ='s full boost at 3,600

have some slight low rpm cruise issues to sort out , but im also running a very tight converter right now till i get my 4l80 back

soon as i get a new shifter cable installed on tuesday ill deff get some driving vids posted up
Reply With Quote Quick reply to this message
  #20 (permalink)  
Old 10-13-2012, 10:58 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 976
Wiki Edits: 0

Thanks: 12
Thanked 33 Times in 30 Posts
drove the car around a lil more today, had one of my fans stop working so i pulle dover on the side of the road to see what was sup since the engine was getting up around 190* and i ende dup having to push the car backwards to pull out cause somone parked infront of me.

lol really need to get that shifter cable and install it, right now i have the trans stuck in drive so i can atleast drive it around to tune it.

overdrive is a waste below 60/65mph car surges real bad ive tried more timing and less timing and nothing helps , might try adding in some more fuel right now im setup for a lean cruise around 15.5-16.2 afrs

other then that this cam seems to be working well

should work even better if i put the single plane intake and lsx 90mm throttle body, the only reason i havent yet is because the ports are 1206/slightly larger on the single plane heads are much smaller
Reply With Quote Quick reply to this message
  #21 (permalink)  
Old 10-13-2012, 11:17 PM
F-BIRD'88's Avatar
Yada Yada Yada
 
Last photo:
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 9,153
Wiki Edits: 0

Thanks: 5
Thanked 380 Times in 374 Posts
waiting got the time slip from your car.
I bet you cannot get past 108MPH and 13.5ets even with tons of boost, with 882 heads.

They are a cork.
Reply With Quote Quick reply to this message
  #22 (permalink)  
Old 10-13-2012, 11:30 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 976
Wiki Edits: 0

Thanks: 12
Thanked 33 Times in 30 Posts
Quote:
Originally Posted by F-BIRD'88 View Post
waiting got the time slip from your car.
I bet you cannot get past 108MPH and 13.5ets even with tons of boost, with 882 heads.

They are a cork.
no slip from that run, old airport drags, on real tires with traction the car would have gone low low 11's maybe high 10's mph supports that pretty well.

u know u may know a whole lot , but u dont know everything, plenty of boosted cars running these heads well into the 10's/11's without trying to hard on both turbo forums and third gen. for a super cheap budget build they have been proven to make good power with turbos plain and simple

fellow fbody guy with a l98 tpi engine that has been featured in a few magazines has gone low 10's with those heads untouched @ 14/15psi and the 882's are just about even, they do flow better but have crappier chambers.


this aint my first rodeo ive built my fair share of turbo cars

and btw my 3.1L v6 with heads that only flow 125cfm broke 330wheel hp and 420wheel ftlbs @9 psi explain that one
3.1 makes 140hp flywheel stock

grand national heads flow about the same and they routinley make 5-600 hp

Last edited by Project89; 10-13-2012 at 11:37 PM.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing / Idle Mac88 Engine 5 08-16-2011 02:53 PM
idle/timing for 383? fireforsin Engine 0 05-29-2006 04:56 PM
timing at idle oldsmo Engine 3 03-20-2005 11:08 AM
timing and idle 5.7jeep Engine 28 11-04-2003 03:21 PM
Rough idle timing 66chevy2ss Engine 6 08-16-2002 12:55 PM


All times are GMT -6. The time now is 10:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.