hydroboost on 99 suburban - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-07-2009, 08:52 PM
Registered User
 
Join Date: Jul 2009
Location: Tacoma, WA
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hydroboost on 99 suburban

i have a 99 3/4 ton suburban with a 454. it is leaking power steering fluid from the hyrdoboost unit where the brake master cylinder/resevoir mounts the the hydroboost unit. is this a common problem? how is it fixed?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-08-2009, 09:59 AM
Registered User
 
Last wiki edit: Wheelbase database Last photo:
Join Date: Jan 2007
Location: Virginia
Posts: 3,647
Wiki Edits: 1

Thanks: 6
Thanked 172 Times in 157 Posts
Quote:
Originally Posted by jameskrusmark
i have a 99 3/4 ton suburban with a 454. it is leaking power steering fluid from the hyrdoboost unit where the brake master cylinder/resevoir mounts the the hydroboost unit. is this a common problem? how is it fixed?
Sounds like time for a rebuilt hydroboost. I had to replace the one on my 99 truck a year or so ago. Not very difficult to do, but remember to take the pushrod, spring, and retainer from your old unit before you return it as a core, since you need to reuse these parts.

DO NOT ask me how I know this...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-09-2009, 09:26 PM
Registered User
 
Last photo:
Join Date: Jan 2009
Location: Springfield, MO
Age: 29
Posts: 1,108
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jameskrusmark
i have a 99 3/4 ton suburban with a 454. it is leaking power steering fluid from the hyrdoboost unit where the brake master cylinder/resevoir mounts the the hydroboost unit. is this a common problem? how is it fixed?
I've got the same problem with my 96 3/4 ton suburban, but i have the 6.5 diesel. I dont think its really a common problem tho because my truck has 250k on it and the hydraboost has never been changed. The part is kinda expensive. $180 from the parts store for an A1 Cardone part and $433 from the dealer for an oem ac delco part. And i dont care much for a cardone part. But i cant afford $433 so cardone is what im gonna have to use.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-10-2009, 02:40 PM
Registered User
 
Join Date: Apr 2009
Location: Fl
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
RE:replacement

Check out tallon hydraulics.com thay have rebuild units with one year warranity all units are tested.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 chevy hydroboost problems dhspyder Suspension - Brakes - Steering 1 11-20-2009 07:59 PM
Installing 53 Suburban modified side glass Sly's 53 Suburban Body - Exterior 0 05-30-2009 10:31 AM
Wheel bearings on 99 Suburban 4x2 ChevyTuff Suspension - Brakes - Steering 2 09-17-2007 01:19 AM
Custom Hydroboost on '69 Torino blacksunshine Suspension - Brakes - Steering 8 08-03-2007 10:44 AM
More hydroboost questions!? 69ChevelleAddict Suspension - Brakes - Steering 8 07-16-2006 07:55 PM


All times are GMT -6. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.