i need help fixing my 350 sbc please - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-26-2011, 09:14 AM
Registered User
 
Join Date: Aug 2011
Location: alberta
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i need help fixing my 350 sbc please

i was driving normally on the highway in 4th gear doing 100kms then pressed the gas to go up a hill and i heard a pop or backfire in the exhause under me then it just died.... i changed the timing chain it was not that but i dont know what it could be??? can anyone please help?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-26-2011, 11:40 AM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Nine Mile Falls, Washington
Posts: 5,222
Wiki Edits: 9

Thanks: 102
Thanked 131 Times in 122 Posts
Wow, the way I figure it 100 kps = 3,728.4 mph, why did you need more speed to get up the hill?

Seriously though, have you checked compression in all cylinders, looked in the distributor, at your valve train?
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-29-2011, 04:06 PM
Registered User
 
Join Date: Feb 2011
Location: edmonton
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
it was 100 kms lol and i did not do any of that no it turns over fine but wont fire and like i said i was driving and it backfired then died i dunno what it can be maybe my heads???
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-29-2011, 07:42 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,654
Wiki Edits: 0

Thanks: 15
Thanked 58 Times in 55 Posts
It sounds as if your taking stabs at the problem instead of doing a proper basic check. The rule of thumb is do the basic checks before you throw major parts such as timing chains or believe the heads are bad.
You have checked to make sure it`s getting spark?
Your sure it`s getting fuel?
Did by chance the distributor bolt work it`s way loose and since the distributor rotates clockwise it moved the distributor housing and retarded the timing so bad it won`t run? As what you discribe happened sounds like a spark timing issue. Have you inspected the valve train to make sure a spring didn`t break or a pushrod?

Last edited by DoubleVision; 08-29-2011 at 07:54 PM.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fixing small plastic tabs/ and fixing toyota bumper tech69 Body - Exterior 2 05-11-2011 08:28 AM
Need help fixing my starter... JJ350 Electrical 4 05-07-2007 05:49 PM
Fixing a wreck fordboy_460 Body - Exterior 1 04-24-2007 07:51 PM
Fixing a sluggish 350 Warrant Engine 19 12-29-2006 06:03 AM
Need help fixing a/c smallz Engine 4 06-10-2003 07:50 PM


All times are GMT -6. The time now is 03:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.