Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   Ididit steering column problem (http://www.hotrodders.com/forum/ididit-steering-column-problem-230327.html)

jkeller 03-04-2013 07:22 PM

Ididit steering column problem
 
I installed a Ididit column on my 57 Chevy 210 and have found out that after I use the turn signal to change lanes my left brake light want work. If I use the turn signal to turn on a street and let it cancel on it's own the stop light works OK.
If anyone has experienced this problem with Ididit columns please let me know what I need to do to correct this safety problem.

MARTINSR 03-04-2013 07:56 PM

Post your question in the electrical forum for many more responses than you will get here. Electrical - Hot Rod Forum : Hotrodders Bulletin Board

WELCOME! :welcome:

Brian

33Willys77 03-04-2013 07:58 PM

Sounds like when the signal mechanism inside doest not cancel all the way and will not let the brake light to function through. I am assuming you are using the left turn signal when changing lanes. If you push the lever just a little more to the right, it would probably work. Something might be a little too tight not allowing it to return to it's 'home' when you release the lever. I never had one, but I believe they use the GM signal switch - might need a new one if you can not free it. Just some thought here.

jkeller 03-04-2013 10:39 PM

Thanks for the suggestions. I will give it a try and see if I can get it to work before replacing it. I will keep you posted.
:welcome:

Bryan59EC 03-05-2013 07:07 AM

Quote:

Originally Posted by 33Willys77 (Post 1653548)
Sounds like when the signal mechanism inside doest not cancel all the way and will not let the brake light to function through. I am assuming you are using the left turn signal when changing lanes. If you push the lever just a little more to the right, it would probably work. Something might be a little too tight not allowing it to return to it's 'home' when you release the lever. I never had one, but I believe they use the GM signal switch - might need a new one if you can not free it. Just some thought here.

Standard 69+GM switch is used in these.
Could try loosening the 3 mounting screws a bit and then snug them up again.

Probably binding.

A weak cancel arm may keep the switch from fully returning as well.


All times are GMT -6. The time now is 01:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.