Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Ignition Problems
View Single Post
  #11 (permalink)  
Old 06-10-2012, 08:30 PM
S10 Racer's Avatar
S10 Racer S10 Racer is offline
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,888
Wiki Edits: 0

Thanks: 3
Thanked 62 Times in 56 Posts
Quote:
Originally Posted by hobby28
Guys my problem is back again, last night was the first hot night at the race track and the same sputter was back on restarts. The car ran awesome after it stumbled and it went the back of the pack. It sputters and almost dies, then it will fire just a little, then it clears itself and runs great until the next caution and restart. I changed the engine late season last year and the problem went away and i am still running that engine, so i am stumped. The fuel pressure gauge fluctuates alot under load, it will go from 8psi clear down to 3psi sometimes. Do you think i could be sucking air in the fuel line somewhere, and how would you test it. Or am i boiling the fuel in the line and once fresh fuel gets pumped up there it takes off?
1. Are you running any type of fuel pressure regulator? The regulator may not be working correctly letting too much fuel back to the tank and dropping your fuel pressure.
2. Check the vent @ the fuel cell.
3. Have you checked the float level on the carb?
4. Do you have a heat isolator between the intake & carb?
5. Check the needle & seat in the carb, it may be sticking.

Last edited by S10 Racer; 06-10-2012 at 08:36 PM.
Reply With Quote