Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - I'll bet I blew an airbag.
View Single Post
  #4 (permalink)  
Old 11-18-2012, 06:05 AM
LATECH's Avatar
LATECH LATECH is offline
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,154
Wiki Edits: 0

Thanks: 199
Thanked 249 Times in 231 Posts
Suspension light came on probably as the compressor ran too long and timed out. Cause yet unknown. Likely suspect leaky bag.
The inlet outlet valve at the bags has also been known to leak as they will get debris and rust in them over the years.
When you get the bags aired back up, squirt them with soapy water, just like checking for a leak in a tire, look for bubbles, even tiny ones like caviar size will be a problem overnight. My guess is you will spot it easily.
The compressor also has a drier on it at the intake. I cut one open here a while back and it was soaking wet and full of rust.
It has something to do with the little air intake box mounted on the core support. Seems it is in a bad place and sucks up water.
Fix the bag that is leaking and be sure to check or replace the drier.
I would pull the drier and squirt brake clean into it, then blow through it with an air hose. If a bunch of rust and trash comes out,replace it, or the compressor will be next.
The drier is full of little silica balls, it is a dessicant to remove moisture
__________________
Fact is stranger than Fiction
Reply With Quote