installed new aluminium heads and have oil leak - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 02-20-2013, 08:51 AM
496CHEVY3100's Avatar
Appalachian American
 

Last journal entry: ,
Last photo:
Join Date: Jul 2012
Location: Appalachia GA
Posts: 880
Wiki Edits: 0

Thanks: 519
Thanked 341 Times in 298 Posts
Quote:
Originally Posted by scharpp View Post
Thanks I was hoping it was just a retorque the heads issue, I raced circle track bump 2 pass cars so these hot rod motors are new to me
I dont think i would try retorque as they have already set gasket,donot overtorque these heads 65 max. i have never ran edelbrock ,I rin Brodix on my dirt motors ,and Trick flow on street motors,
Attached Thumbnails
Click image for larger version

Name:	026.jpg
Views:	31
Size:	199.7 KB
ID:	71549   Click image for larger version

Name:	003.jpg
Views:	36
Size:	465.0 KB
ID:	71550  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 02-20-2013, 09:00 PM
scharpp's Avatar
1938 International D2
 
Join Date: Feb 2013
Location: East Wenatchee Washington
Posts: 5
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
oil leak

My heads are Dart pro4 anyone have this problem with theae headds
Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 02-20-2013, 09:11 PM
496CHEVY3100's Avatar
Appalachian American
 

Last journal entry: ,
Last photo:
Join Date: Jul 2012
Location: Appalachia GA
Posts: 880
Wiki Edits: 0

Thanks: 519
Thanked 341 Times in 298 Posts
Never saw a problem with Dart heads.is your block .O Ringed with stainless wire.
Reply With Quote Quick reply to this message
  #19 (permalink)  
Old 02-21-2013, 08:27 AM
scharpp's Avatar
1938 International D2
 
Join Date: Feb 2013
Location: East Wenatchee Washington
Posts: 5
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
I dont know as it was built when I bougt the truck
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.