Installing powertrax trouble - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-25-2005, 11:07 PM
Registered User
 
Join Date: Nov 2004
Location: SC
Posts: 31
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Installing powertrax trouble

I viewed several powertrax questions but found none like this one.

Im installing a powertrax unit in chevrolet 10 bolt 8.5 with an open carrier. After removing the spider gears and thrust washers, I noticed a washer like/shem between the spider gears/thrust washers and the housing itself. Powertrax instructions do not mention if these things should stay in or not, so I tried to install the unit and it was too snug of a fit, so I assume i need to take these washers out??? I'm not talking about the thrust washers, these parts are about 3" in diameter and are between the spider gears and the housing on both sides. Just dont know what to do. Any help appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-26-2005, 01:24 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: Espaņa Right Coast
Posts: 3,259
Wiki Edits: 0

Thanks: 90
Thanked 92 Times in 78 Posts
How big are these extra "shims" ?
I donīt understand your last sentence, are you describing the thrust washers as they are large and found each side of the spider gears or are you describing the "Extra shims" you found, or are you talking about "C" clips.
I bought a new pack of thrust washers when installing mine, and they are mentioned in the instruction manual.

Attached Thumbnails
Click image for larger version

Name:	Powertrax.jpg
Views:	324
Size:	61.6 KB
ID:	4034  

Last edited by M&M CUSTOM; 02-27-2005 at 09:45 PM. Reason: Showing picture.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kids and trouble Kevin45 Hotrodders' Lounge 15 02-20-2006 04:27 PM
installing powertrax camino_man Transmission - Rearend 6 12-18-2004 05:33 PM
Help installing hei distributor iroc_Camaro388 Engine 3 01-30-2004 12:05 AM
Trouble Installing Oil Rings 57Chevyman Engine 4 04-10-2002 02:30 PM
c4 transmission trouble Steve W Transmission - Rearend 2 11-04-2001 07:04 PM


All times are GMT -6. The time now is 06:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.