iron duke... very retarded (literally) - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 12-02-2003, 12:59 PM
dukin-it-out's Avatar
Imports Are Evil
Join Date: Aug 2003
Location: Ventura, California
Age: 33
Posts: 57
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
iron duke... very retarded (literally)

2.5L Iron duke... 8.3 or so compression (electric fan conversion, 165degree thermostat, but all stock)

Reman head, new plugs, wires, dist cap and rotor.

88 Chevy S-10, 5spd... TBI

ok well, my head gasket blew, and i ended up swapping on a FWD head, and it pinged like crazy and ran like crap... I havent touched anything timing related.

Anyways... now... about 5 months after the head swap, ive been noticing it hesitating, uasually in 3rd 4th or 5th, when i give it gas, usually around 2500 and up.

no matter what gas i run, it always seems to do it.. it just hesitates and hesitates for about 2 or 3 seconds when i give it, even moderate gas.

I checked my timing today, for the first time in a while, and its reading about -15 degrees at idle, and i didnt check for when it kicks it up.

Well i have never done timing, so thats why im posting on here before i go screw something up. I am guessing i want to set it up around 0 and then see where to go from there. More power is always a plus, but never easily obtained on my engine.

I just posted on here, to make sure it IS the problem, and im not going to make anything worse, or anything i should know before i follow the instructions under the hood... aka ground this, and so on so forth.... concidering it is EFI.

Any help is appriciated.

Would Negitive Timing (thats numbers BTDC right?) make me miss? i thought more positive numbers would lead to ping... maybe it works both ways

Thank you everyone!



Last edited by dukin-it-out; 12-02-2003 at 01:07 PM.
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 03:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.