Its an engine - Page 4 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #46 (permalink)  
Old 04-27-2013, 11:40 AM
Registered User
 
Last photo:
Join Date: Aug 2011
Location: Fort Worth, TX
Posts: 522
Wiki Edits: 0

Thanks: 153
Thanked 11 Times in 10 Posts
BEAST! Have fun with that thing!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #47 (permalink)  
Old 04-27-2013, 11:47 AM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 2,072
Wiki Edits: 0

Thanks: 82
Thanked 316 Times in 273 Posts
Quote:
Originally Posted by Hogg View Post
Sounds like its in a 3rd Gen F-body. Is it?

SOunds good.

peace
Hog
That it is sir
Reply With Quote Quick reply to this message
  #48 (permalink)  
Old 04-27-2013, 02:11 PM
Registered User
 
Last photo:
Join Date: Aug 2011
Location: Fort Worth, TX
Posts: 522
Wiki Edits: 0

Thanks: 153
Thanked 11 Times in 10 Posts
mmm
Reply With Quote Quick reply to this message
  #49 (permalink)  
Old 04-28-2013, 09:27 AM
66GMC's Avatar
Get in, sit down, hang on
 

Last journal entry: Cab Removal
Last photo:
Join Date: May 2005
Location: Olds, Alberta Canada
Age: 57
Posts: 2,763
Wiki Edits: 0

Thanks: 32
Thanked 91 Times in 86 Posts
Quote:
Originally Posted by sbchevfreak View Post
Not to thread jack....

Hey, 66, was it the WIX filtration and lubrication seminar with the guy from BOSS lubricants?
Yes the WIX guy from North Carolina, but the other guy was Art Wilderman from AIA.
Reply With Quote Quick reply to this message
  #50 (permalink)  
Old 04-28-2013, 04:19 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 2,072
Wiki Edits: 0

Thanks: 82
Thanked 316 Times in 273 Posts
Spent some quality time today getting acquainted with my Holley lol. Was pig rich on idle yesterday, smoke out the tail pipes and made my wife sick when she followed me through town. Plugged all vacuum ports. Then started from scratch with the idle screws 1.5 turns out. Couldn't control idle no matter what I did. So reset the float levels, they were a touch high, then pulled Carb and closed up rear transfer slots until almost completely closed. Reset fronts to square, the reinstalled. Now had control of my idle finally. Idle at 1000, my 12yr old daughter in the car, on the brakes in gear, turned the mixture screws in until it started to stumble, then back out 1/4 turn. (No vaccum guage handy) then back in park. Hooked up vacuum advance to manifold source. Idle jumped up, adjusted back down until 800rpm, and 650 in gear, no more smell, no more smoke, and the response is amazing. Its neat what an hour of time and some effort will accomplish lol.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 Crate Engine: Loud humming sound after engine warms up sofa1515 Engine 2 01-11-2010 07:48 PM
I need engine mount bracket ideas 1930 chevy with 302 boss engine. Riley Engine 3 07-25-2008 08:29 AM
Ford 302 engine to engine stand bolt size? Lee in Texas Engine 4 03-24-2008 11:30 AM
95 ford F-150 engine swap, Same Transmission fit new engine? F-150 Transmission - Rearend 5 10-07-2007 01:11 PM
say you have a THOUSAND horsepower engine..... (technical engine question inside) lowROLLERchevy Engine 14 02-24-2007 09:26 AM


All times are GMT -6. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.