Its an engine - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-18-2013, 08:18 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,781
Wiki Edits: 0

Thanks: 54
Thanked 249 Times in 216 Posts
Its an engine

Hope this doesn't get moved to obscurity....it is after all, an engine
Motor was so clean when the old heads came off, I could actually clearly read the pn# on the top lol.....speedpro flat tops, 30 over. New heads installed tonight with arp bolts, intake is just sitting for hood clearence check but had to snap a pic.....so happy! Will hopefully have running saterday......then goes to have the hood painted matte black,and the wheels powder coated black.....thats all for now, I'm sure I will have Carb and timing questions soon for here.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #3 (permalink)  
Old 04-18-2013, 09:15 PM
Custom10's Avatar
my KARMA ran over my DOGMA
 

Last journal entry: SS
Last photo:
Join Date: May 2009
Location: Saskatchewan, Canada
Age: 49
Posts: 1,095
Wiki Edits: 0

Thanks: 14
Thanked 25 Times in 23 Posts
Tech are you surfing from your lazy boy again?.

Dont forget link to fuel pressure check out,,,or is it in there somewhere?

TJ
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-18-2013, 09:24 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,781
Wiki Edits: 0

Thanks: 54
Thanked 249 Times in 216 Posts
I just burst out laughing...
TDC was verified with a stop before I pulled the heads, balancer is accurate
Cam was already installed and i left it alone and did stay with 1.5 rockers as per your recommendation
Valve adjustment I haven't yet had a problem with on past builds, and do use the "jiggle up and down" method as opposed to spinning them
Carb, well in theory it should have a VC instead of the 750dp but I always prefer mechanical and have had success making them work for me.
Drop base I have, and the hood looks like it closes with a 1/2 inch to spare even with a 1" spacer
Vaccum leaks.....don't know yet but lets hope not
HEI has been modified by previous builder, has a 15 curve and is all in by 2500
And i left the short block as is, stock crank, "pink" rods, speedpro hypers, zero decked, lots of expensive machine work and arp throughout. With receipts to verify and approx 8000k since it was done.
So will hope this goes smoothly the rest of the way. Still have to reinstall exhaust, set lash, intake, dist, plugs, wires, fluids, pushrods should be here tommorow, so aiming to fire it saterday.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 04-18-2013, 09:48 PM
Custom10's Avatar
my KARMA ran over my DOGMA
 

Last journal entry: SS
Last photo:
Join Date: May 2009
Location: Saskatchewan, Canada
Age: 49
Posts: 1,095
Wiki Edits: 0

Thanks: 14
Thanked 25 Times in 23 Posts
Great, it is about to roar,,,good luck
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 04-18-2013, 10:23 PM
1Gary's Avatar
Registered User
 

Last journal entry: 383 dyno sym
Last photo:
Join Date: Oct 2010
Location: Roch,NY
Age: 66
Posts: 1,524
Wiki Edits: 0

Thanks: 201
Thanked 156 Times in 142 Posts
With everything you have been through with this,can't think of anyone more deserving of clear sailing from this point out.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 04-18-2013, 10:33 PM
spinn's Avatar
Strawberries never die
 

Last journal entry: This makes a huge difference
Last photo:
Join Date: Oct 2004
Location: Midnight
Posts: 2,460
Wiki Edits: 0

Thanks: 12
Thanked 80 Times in 78 Posts
She is a beauty. Good luck.

8k Yikes!
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 04-18-2013, 10:40 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,781
Wiki Edits: 0

Thanks: 54
Thanked 249 Times in 216 Posts
Quote:
Originally Posted by spinn View Post
She is a beauty. Good luck.

8k Yikes!
Lmao.....I'm Canadian, 8000 kilometers since it was built.....
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 04-18-2013, 10:42 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,781
Wiki Edits: 0

Thanks: 54
Thanked 249 Times in 216 Posts
Thanks for the kind words gentlemen.....I hope it makes a fun little street motor.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 04-18-2013, 11:00 PM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,881
Wiki Edits: 0

Thanks: 3
Thanked 59 Times in 54 Posts
It does look good. Do yourself a favor and get rid of that Fram oil filter. Congrats!!!
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 04-18-2013, 11:32 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,791
Wiki Edits: 326

Thanks: 742
Thanked 956 Times in 806 Posts
Quote:
Originally Posted by Custom10 View Post
Tech are you surfing from your lazy boy again?.
Was it that obvious?
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 04-19-2013, 01:51 AM
Registered User
 
Last photo:
Join Date: Jun 2010
Location: Finland
Posts: 195
Wiki Edits: 0

Thanks: 7
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by S10 Racer View Post
It does look good. Do yourself a favor and get rid of that Fram oil filter. Congrats!!!
What`s wrong in a Fram filter?
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 04-19-2013, 02:00 AM
gearheadslife's Avatar
MentalMuffinMan
 
Last photo:
Join Date: Nov 2012
Posts: 2,157
Wiki Edits: 0

Thanks: 94
Thanked 268 Times in 250 Posts
Quote:
Originally Posted by TimoFinn View Post
What`s wrong in a Fram filter?
that fact that they pass it off as a filter..
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 04-19-2013, 02:58 AM
1Gary's Avatar
Registered User
 

Last journal entry: 383 dyno sym
Last photo:
Join Date: Oct 2010
Location: Roch,NY
Age: 66
Posts: 1,524
Wiki Edits: 0

Thanks: 201
Thanked 156 Times in 142 Posts
wix!!!! Please
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 04-19-2013, 03:18 AM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,781
Wiki Edits: 0

Thanks: 54
Thanked 249 Times in 216 Posts
Quote:
Originally Posted by S10 Racer View Post
It does look good. Do yourself a favor and get rid of that Fram oil filter. Congrats!!!
Had read that here before, and yep, will be doing so tonight for sure....that was the PO that thought it was a good idea to use fram
Thanks!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 Crate Engine: Loud humming sound after engine warms up sofa1515 Engine 2 01-11-2010 06:48 PM
I need engine mount bracket ideas 1930 chevy with 302 boss engine. Riley Engine 3 07-25-2008 07:29 AM
Ford 302 engine to engine stand bolt size? Lee in Texas Engine 4 03-24-2008 10:30 AM
95 ford F-150 engine swap, Same Transmission fit new engine? F-150 Transmission - Rearend 5 10-07-2007 12:11 PM
say you have a THOUSAND horsepower engine..... (technical engine question inside) lowROLLERchevy Engine 14 02-24-2007 08:26 AM


All times are GMT -6. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.