joek - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-11-2012, 09:30 PM
Registered User
 
Join Date: Oct 2012
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
joek

1990 f250 351w efi, loss of power above 3000 rpm, change fuel filter, could injectors be dirty?

    Advertisement

Last edited by joek; 10-11-2012 at 09:31 PM. Reason: miss spell
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-11-2012, 09:34 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,060
Wiki Edits: 1659

Thanks: 316
Thanked 97 Times in 94 Posts
Moving to basics forum. Please ask tech questions in tech forums
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-11-2012, 09:54 PM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 56
Posts: 7,413
Wiki Edits: 0

Thanks: 292
Thanked 707 Times in 682 Posts
Its your fuel pump maybe.I had the same truck and same problem.Is it dial tanks?does this same problem exist with both tanks? Hows the mileage,lol?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-17-2012, 01:03 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Check the fuel pump and regulator. What's the timing set at?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-17-2012, 07:18 PM
Richiehd's Avatar
JS-70
 
Last photo:
Join Date: Jun 2011
Location: Jupiter FL
Posts: 828
Wiki Edits: 0

Thanks: 144
Thanked 55 Times in 48 Posts
Quote:
Originally Posted by joek View Post
1990 f250 351w efi, loss of power above 3000 rpm, change fuel filter, could injectors be dirty?
Check Catalytic Converters.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
joek joek Introduce Yourself 1 10-12-2012 11:03 PM


All times are GMT -6. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.