Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
hotrodders.com: Project Journals: grapro's Journal
User Name
Password
lost password?   |   register now

View grapro's profile Entries: 208
Views: 111486
view from the beginning || now viewing most recent entries


Pages (42): 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 [18] 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42

10-31-2007 10:46 PM Running
Finally got it running pretty loud with open pipes, baffles will be my next project. Just need to mount the driveshaft and I'll go down the alley this weekend


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #123]

10-31-2007 10:39 PM Blower Blowing
With the manifold done I mounted the blower and carb, finished the walker rad installation and had to make a idler pulley and bracket. Made the bracket out of a piece I had left over from the manifold and had a good buddy of mine machine a couple of bearing races into a crank pulley I got at a swap meet and I was ready to fire. Used a turnbuckle from another bracket and a old gasser style header alternater bracket to make mine work.


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #122]

10-31-2007 10:30 PM Welded up the Manifold
Got a buddy of mine to weld up my manifold, He did it right on the truck.Had a nice aluminum spool gun and did a amazing job.


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #121]

10-11-2007 10:43 PM Getting ready to Fire
Redid my manifold, it was too high and unperportional to the truck. Dropped it five inches and the supercharger looks alot better. just need belts and rad hose and it will be running.


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #120]

10-06-2007 10:54 PM Motor Mockup Again
Put the motor back in again, have to see how it will work with the new rad, I had to move the motor back a inch to clear my bottom pulley. Looked easy but I had to cut out my trans tunnel so I could make it work, You would think after installing the motor about ten times I would have it figured out by now.


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #119]

Pages (42): 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 [18] 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42


All times are GMT -6. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.