Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
hotrodders.com: Project Journals: saltbob's Journal
User Name
Password
lost password?   |   register now

View saltbob's profile Entries: 23
Views: 1575
view from the beginning || now viewing most recent entries


Pages (5): [1] 2 3 4 5

11-03-2012 04:41 PM Iembarrassed about starter problem!
I went to Nasty Z28 site and they finally got it thru my thick head the flexplate was on backwards all along
all of you were right all along and I do Thank everyone trying to help me. I turned it around and it works
just fine I may try to start later to day. The gear still does not go all the way on but works just fine I put
a remote switch on and checked it. I just need to save money for a transmission rebuild. Thanks again!!

  [Entry #23]

10-16-2012 12:49 PM 84 vette transmission
F=650 I found a good transmission man, he said I didnt need a 4000 stall converter unless it was going
to be raced, he will replace with more of a street/strip converter, he will fix transmission and I can
drive home from the shop $850 also I will need a shifter and starter/flexplate fixed would be
extra
Also I thought people might like to see photos of F-650 and various
engines and cars from
TMS Fall 2011


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #22]

10-16-2012 11:27 AM 84 vette photos
wheelie damage done before I got the car Aug. of 2011--- The
person you can just make out i picks of car with hood open
was my friend and helper he went with me to get the car in Jones Creek Tx. 2011 We half way joked about him being my driver at local drag races when the vette was ready he unfortunately drowned at Marine Creek Lake summer of 2012 he will be missed.
R,I.P. Nathan Newberry


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #21]

10-07-2012 06:38 PM popping noise from 5.4 Triton
THANKS for all the info popping noise problem everyone was right I put in new plug and I think It came
loose over a long period of time when I stopped the truck about a block later the spark plug and broken
coil were laying loose on the top of the engine. The new plug tighten up ok and I hope piston is not
damaged also replaced coil but the engine still had a miss it it the service tech said it needed no 1 and no
4 coil replaced I should be able to do that for about $110 not the $400 he would charge,

ALSO 1984 Hot Rod Corvette. after posting I enlarged
flexplate and starter gear and it looks worn off also.

BACK to 5.4 Triton engine problem FIXED 1 new coil plug and 4 new
spark 2 on each side at the front, 1 special magnetize socket Like i
said I got luckey


(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)

(click photo to enlarge)
  [Entry #20]

10-05-2012 09:30 AM popping noise from cylinder head
I dont know if this is the right place for this but I got lucky on F-250 popping noise I had new plugs put in about a year ago $300 this plug was not tight enough over time it backed out untill it blew out of engine splitting the rubber boot and breaking the coil the threads were OK I put in new new plug and coil $54 and good to go Thanks to all I just wanted to let everyone know saltbob

  [Entry #19]

Pages (5): [1] 2 3 4 5


All times are GMT -6. The time now is 08:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.