Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
hotrodders.com: Project Journals: Magikal's Journal
User Name
Password
lost password?   |   register now

View Magikal's profile Entries: 5
Views: 1082
view from the beginning || now viewing most recent entries



04-02-2005 11:16 AM Been a long Winter
I haven't been very up to date on the pics here or anything but thanx to old man winter in North IDaho here, I didn't get very much accomplished as my garage is not heated. The engine does run now (quite well too) and I have the gas tank in working order now as is the wiring. I still am in search of a transmission and I think the time has come for it.


(click photo to enlarge)

(click photo to enlarge)
  [Entry #5]

09-07-2004 08:12 PM Pitfall #1
After getting the motor on the engine stand it was discovered that (1) the cylinders all have compression (yeah!!) and (2) there is a crack between two freeze plugs. On the bright side, it is contained within a water jacket so a welder should be able to fix the crack easily enough and some new freeze plugs. I think I may just drop it off at the shop for a full overhaul. It does have compression though.....hmmm....

I would scrap the whole motor but the numbers on the motor match the ones on the car. Original motor!!


(click photo to enlarge)
  [Entry #4]

09-07-2004 08:02 PM Labor Day Weekend
My holiday at work here. Aluminum motor so I went with the Silver paint....Grabber Green got my attention and after debate with the girlfriend we decided to highlight the engine compartment and engine in the green. You either like it or you don't. Not being a professional bodyman or anything I am sure it isn't the best but it is better than before!!


(click photo to enlarge)
  [Entry #3]

09-07-2004 07:55 PM Under the hood
ok, after 3 hrs we got the hood open and behold, the original motor w/ matching serial numbers is sitting here. It hasn't ran in 9 years but it ran when parked.


(click photo to enlarge)
  [Entry #2]

09-06-2004 08:58 PM It used to be Granpas
Well, I drove this to Idaho from Cali in 1995. The tranny went out after a year and then it sat until now. Getting it to my garage finally!!


(click photo to enlarge)
  [Entry #1]



All times are GMT -6. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.