K1500 ABS disabling? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-13-2011, 03:25 PM
Member
 
Last wiki edit: Ford axle ratio codes
Last journal entry: Rear Suspension
Last photo:
Join Date: Aug 2005
Location: Prattsville
Posts: 6,349
Wiki Edits: 31

Thanks: 2
Thanked 53 Times in 49 Posts
K1500 ABS disabling?

My '95 K1500 has developed a bad brake 'grab' at times, when it's first started to be driven ( clears up after a few miles ). Many times this is accompanied by an ABS light.. Asked the mechanic I use about checking the ABS codes with his scanner and he said to just pull the fuse and drive it, as the OBS trucks are better without it, which is not the first time I'v been told the primitive Kelsey Hayes system is no good, and it no longer activates anyway. it used to, but never like it should.. I do not like lights on the dash and will not perform this 'modification' unless the dash light can be turned off short of cutting wires or pulling the bulb, or black tape.. Problem is, I'm not even sure the grab is caused by the ABS .

can ABS light be turned off?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-16-2011, 08:00 AM
Registered User
 
Last wiki edit: Wheelbase database Last photo:
Join Date: Jan 2007
Location: Virginia
Posts: 3,516
Wiki Edits: 1

Thanks: 6
Thanked 144 Times in 131 Posts
There are millions of these trucks on the road with the factory ABS working just fine (mine being one of them). Find a mechanic who has a clue, or buy a factory service manual and learn how to fix it yourself.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
tbi 350 k1500 cam help? musclecarsrock68 Engine 34 07-27-2011 09:16 PM
95 tbi k1500 hp musclecarsrock68 Hotrodding Basics 34 07-19-2011 04:17 PM
91 k1500 350 tbi gabes91 Engine 3 02-21-2011 10:48 AM
92 chev k1500 4x4 budnick Suspension - Brakes - Steering 1 04-04-2008 01:38 PM
disabling rear drum brakes nitro3421 Suspension - Brakes - Steering 3 03-14-2006 05:47 PM


All times are GMT -6. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.