kwik wirw problems - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 07-12-2007, 08:38 PM
Registered User
Join Date: Jul 2007
Location: fort smith,AR
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
kwik wire problems

I have been trying to install a Kwik Wire brand wiring harness into my "27 t bucket.
The wiring harness seems to be set up to use a gm steering column, but I have made my own steering column and had to purchase the Kwik Wire turnsignal switch.
The wiring instructions are proving very difficult to understand and phone calls to Kwik Wire get a response that indicates they think I'm pretty stupid and they seem very "put out" to have to answer any questions.
Anybody else had this problem?
I'm ready to rip the whole harness out and send it back to them, does anybody have a recommendation on what brand wiring harness I should buy?


Last edited by rodrod; 07-12-2007 at 08:51 PM.
Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 07-12-2007, 08:51 PM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,840
Wiki Edits: 0

Thanks: 1
Thanked 90 Times in 77 Posts
Sorry your having problems with your harness. You can go to the Painless Wiring website and download a manual that will be a big help trying to figure out the turn signal wiring. There will be some differences in the color codes but it is fairly easy to figure it out.

Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-12-2007, 08:52 PM
docvette's Avatar Moderator
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 63
Posts: 7,360
Wiki Edits: 12

Thanks: 0
Thanked 7 Times in 4 Posts
Doc here,

Ron Francis..about $600 to $1000 for the complete kit..only problems is they seem to be having a run of bad ignition switches..

Aftermarket Solutions
Electronic & Electrical
Reply With Quote Quick reply to this message

Recent Electrical posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker problems and ways to fix them leftoverchrisac Engine 15 02-06-2009 06:36 PM
Olds 98 Ignition Module Problems awbazar Electrical 1 01-12-2004 07:42 AM
beater car problems 02 0n 20s Engine 2 11-01-2003 07:53 PM
Light Problems like crazy ponybuster Electrical 7 10-14-2003 01:12 PM
LT1 knocking problems gollygwagen Engine 0 04-23-2003 06:52 AM

All times are GMT -6. The time now is 10:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.