lack of horses - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-04-2004, 08:08 PM
Registered User
 
Join Date: Mar 2004
Location: Houston TX
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Question lack of horses

I have a 74 chevy 1/2 ton w/350 4bolt. This is the original motor, when Igot the truck the cam was completly rounded. I have changed the cam,intake manifold,carb,&dist.This motor came with a 2bbl and this what was replced with. When you go to take off the motor tries to cut out but if u feather the gas pedal it comes back around but with serious lack of power. I know this motor is strong a friend has same setup and running fine. PLEASE HELP!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-04-2004, 08:12 PM
lluciano77's Avatar
Short changed on common sense
 
Last photo:
Join Date: Jun 2003
Location: california
Age: 37
Posts: 3,548
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It sounds like your accelerator pump shot is weak. Give it more gas on the accelerator shot.

You may need a different power valve as well. When you add a performance cam your vacuum changes, and so does the powervalve opening requirement.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-04-2004, 08:15 PM
FASTCHEVY's Avatar
RatRod B4 RatRods were Cool
 
Last photo:
Join Date: Feb 2004
Location: Dallas Texas
Age: 32
Posts: 800
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Could be a timing prob.

What have you replaced on the truck?


Power valve? how do you know he has a Holly?

We need more info.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-04-2004, 08:39 PM
BstMech's Avatar
NYOFP4RJ3CHRIS
 
Join Date: Sep 2002
Location: TN. In the corporate states of America
Age: 41
Posts: 1,552
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally posted by FASTCHEVY
Power valve? how do you know he has a Holly?
Who said anything about it being a Holley?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-04-2004, 11:24 PM
4 Jaw Chuck's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Mar 2002
Location: Manitoba, Canada
Age: 46
Posts: 4,995
Wiki Edits: 0

Thanks: 2
Thanked 91 Times in 74 Posts
Sounds like the thing needs some TLC and an overhaul...start with the carb.
__________________
Outlawed tunes from outlawed pipes
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-05-2004, 11:44 AM
funk master flex's Avatar
Registered User
 
Join Date: Mar 2004
Location: california
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
how do you know holly
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-05-2004, 01:00 PM
Muscle car fan
 
Last photo:
Join Date: Mar 2003
Location: Manitoba, Canada
Posts: 864
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
carb and or timing

did you get rid of the EGR when you got your new manifold?
may need to re-curve your distributor

why are you jumping all over the "how do you know he has a holley" stuff people? this is supposed to be a friendly board
__________________
'74 Gran Torino Project
351W, c6 trans, 9"

Last edited by Dubz; 03-05-2004 at 01:06 PM.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-07-2004, 08:25 PM
Registered User
 
Join Date: Mar 2004
Location: Houston TX
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yes it's a Holly. It's a 2BBL on a 4BBL manifold. The distributor has been completely rebuilt. The EGR valve is gone. New timing chain and sprocket. Timing is dead on at 8 degree. Using an abundant amount of gas. Occasionally backfires through the carburetor. This is a stock 32K V coil, would it help to go to a higher voltage coil, possibly not enough spark?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.