Leaking TH350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-14-2005, 09:08 PM
MEAN_SBC's Avatar
Member
 
Last photo:
Join Date: Jul 2004
Location: Amarillo, Texas
Age: 36
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Leaking TH350

I just got the engine and tranny in my brothers 68 Chevelle. The transmission was rebuilt by a transmission shop here in town. I've got the o-ring on the dipstick, but on the kickdown cable, is there supposed to be an oring, or rubber bushing there to keep it from leaking???? Whenever the fluid level get's above pan level, it starts pouring out the front right side somewhere. I'm trying to figure out what it is... Any ideas??? Thanks in advance....

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-14-2005, 09:17 PM
Rob Keller's Avatar
AKA:"SLOWRIDE66"take it easy!
 
Last wiki edit: How to post pictures on a forum
Last journal entry: 85 Suburban
Last photo:
Join Date: May 2004
Location: Central Florida U.S.A.
Age: 48
Posts: 4,297
Wiki Edits: 38

Thanks: 0
Thanked 1 Time in 1 Post
there is 2 types i know of
1 o ring
2 a rubber grommet

the o rind type should have a groove
put it in dry(without any thing)
if it goes in really sloppy it the grommet
if its tight then its a o ring type
__________________
"SlowRide66"

"Illegitimis non carborundum"
Don't let the bastards grind you down!

Crankshaft Coalition Master List of Hotrodding Forums
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-15-2005, 11:55 AM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,101
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
IF your detent cable end uses the rubber sleeve seal..... install the sleeeve into the tranny case FIRST. then lube the cable end and push in gently
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-15-2005, 10:04 PM
BTW...ur left headlight is out
 
Join Date: May 2005
Location: Plano TX
Age: 27
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
where exactly is it coming from on the front right side? the vent tube is one the right side...i had the O-ring off my TH400 come off on the filter and it would spit tranny fluid out of the over flow tube. also...do you have all the gears? like is it moving foward and backwards?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-15-2005, 10:11 PM
MEAN_SBC's Avatar
Member
 
Last photo:
Join Date: Jul 2004
Location: Amarillo, Texas
Age: 36
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Moves fine.... I actually found the problem today. The rubber o-ring seal on the kickdown cable wasn't on it, and when the fluid got to that level, it would just pour out.... Thanks guys!!!
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TH350 driveshaft yoke leaking Jmark Transmission - Rearend 11 08-16-2008 11:38 AM
th350 leaking only under load justspeed Transmission - Rearend 6 10-31-2004 03:18 PM
th350 leaking only under load justspeed Transmission - Rearend 10 10-06-2004 09:03 PM
Leaking TH350? frankenvette Transmission - Rearend 2 09-28-2004 05:08 PM
Leaking TH350 Malibu1980 Transmission - Rearend 2 11-07-2003 07:04 PM


All times are GMT -6. The time now is 10:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.