Lean blower engine? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-03-2009, 07:18 PM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Lean blower engine?

Hi folks...
This is my first post. However...I have been coming here and reading for a couple of years now. The site is great and some of the most engine knowledgeable people on the net are in here.

I'm probably going to end up answering my own question in this post, but I still like to bounce ideas off guys "in the know".

First thing I would like to make clear is that the engine I am going to ask the question about is a "race only" engine. This is in a sand drag Jeep. For those who don't know...a sand drag strip is only 300 feet long.

The motor is fresh, I'll give you a few details.
357 inch SBC
9.2 comp (static)
zero decked with 0.38.
Brodix IK 200 heads
Steel crank
Cam is a Lunati, 244/254 @0.50, 509/533, LSA/ICL 112/107
Two Holley 660 center squirt carbs (yeah, really)
On a 671 large bore.
The blower has a 35 pulley on top and a 39 on the bottom. I think this makes it 11% overdriven.
The ignition is a Mallory comp 9000, locked at 28 with no box (yet), just distributor, voltage resistor and coil.
As you can see...this is a pretty "mild" motor (as far as race motors go). But believe me...it does not feel very mild in a 1,520 pound drag Jeep with a 6.50 rear and a glide.

Here is what is going on...from idle, it hits very hard (probably because of the massive amount of fuel the center squirts dump in when you goose it.

But with a load on it...it lays down (feels like a rev limiter) at about five grand.

I have a 4000 stall with a brake. The instant I let my finger off the brake, it lays down.

I forgot, I am running a Holley pump. It's a "volumax" two feed lines and a return line from the pump back to the tank, 10 AN lines. I have it set to 7.5 psi and it holds that 7.5 psi, even when it's laying down.

The 660's have no power valves.

I started out with it having 76 jets (square). Which was fine for cam break in. I noticed it not wanting to pull hard with a load on it, so I went to 82 jets (square again). It seemed to make very little difference (if any).

I took a look at the plugs, they are a little lean (not terrible) but I let out of the throttle as soon as it starts to lay donw, because I know what a lean forced induction motor will do (I know it too well).

Here's the thing...I actually HAVE a wide band tuner. But I am running "zoomies" for exhaust. Do you think that putting the sending in one tube would give me an accurate reading? Or would it be better than nothing?

I know that asking "what size jets" I should run is not a question that anyone but me can really answer. But....does 82 jets in the primary and secondary of both carbs seem like it should be lean on such a mild sbc? Or should I be looking at the Unilite as the possible suspect?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-03-2009, 08:34 PM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,263
Wiki Edits: 326

Thanks: 610
Thanked 770 Times in 660 Posts
Personally, I'd "fat it up" 'til it wouldn't run, then start back the other way.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-03-2009, 09:36 PM
carsavvycook's Avatar
My 2 cents worth
 
Last photo:
Join Date: Sep 2007
Location: Lakeside, CA
Age: 57
Posts: 2,855
Wiki Edits: 3

Thanks: 2
Thanked 2 Times in 2 Posts
Your rear gear is pretty high, and your engine is a low torque monster, IMO. since it lays down at 5 grand.

1st. Check to make sure your carbs are going full throttle with the pedal on the floor.

2nd. Try re-jetting the secondaries up to 87's, or 91's. This should allow you to bump up the timing to 32 degrees total.

3rd. Consider dropping the rear gear into the high 500's, such as a 587, or a 598. This would help to lower your top engine rpm's back into your engine's power band.

What fuel are you running, and what spark plug, and plug gap?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-03-2009, 11:06 PM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by carsavvycook
Your rear gear is pretty high, and your engine is a low torque monster, IMO. since it lays down at 5 grand.

1st. Check to make sure your carbs are going full throttle with the pedal on the floor.

2nd. Try re-jetting the secondaries up to 87's, or 91's. This should allow you to bump up the timing to 32 degrees total.

3rd. Consider dropping the rear gear into the high 500's, such as a 587, or a 598. This would help to lower your top engine rpm's back into your engine's power band.

What fuel are you running, and what spark plug, and plug gap?
I know that 6.50 sounds like a very low gear (even for 300 feet). I know I personally was shocked when I first started sand racing 10 years ago. Believe it or not...I am one of the few guys who are not in the sevens. Many are 7.50. The rear tires are a little over 34 inches tall, so it works out.

I should have mentioned that the gear ratio was set with my last motor (which was of similar build) I like to have it turning about 6,500 when it goes through the traps (about 100 mph) and 6.50 hits that number for me (with my last engine anyway).

I'm running 114. and my gap is 0.35.

Both of you have a good point on fattening it up...I mean really...it's most certainly not going to hurt anything but spark plugs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-03-2009, 11:47 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 7,678
Wiki Edits: 0

Thanks: 10
Thanked 149 Times in 137 Posts
I would also be concerned with that much overdrive and the amount of heat it must be creating in the fuel charge. That is a lot of overdrive % + that high of a static compression ratio. Maybe take a look at some of the drive charts vs comp ratio at the BDS web site. Why so much overdrive?? There comes a point when efficiency goes away with too much blower rotor speed.

660's with no power valves I would expect to jet at 82-83 front NATURALLY ASPIRATED. Are you set up to jet both sides? (they come stock with a rear metering plate)
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-04-2009, 12:37 AM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ericnova72
I would also be concerned with that much overdrive and the amount of heat it must be creating in the fuel charge. That is a lot of overdrive % + that high of a static compression ratio. Maybe take a look at some of the drive charts vs comp ratio at the BDS web site. Why so much overdrive?? There comes a point when efficiency goes away with too much blower rotor speed.

660's with no power valves I would expect to jet at 82-83 front NATURALLY ASPIRATED. Are you set up to jet both sides? (they come stock with a rear metering plate)
Yeah, it is sort of set on kill...but remember, I am on the throttle for around 3.5 seconds total, then idle down the return road.

The 355 I had this blower on last time, boosted 14 psi at 6000 rpm. I know this puts my compression right up there...but, again, it's 300 feet in a very low geared, light car on 114.

However...if you think that it's over driven too much and would go faster with less boost, I am all about trying it. I got nothing to lose.

I can't "jet" both sides, because the carbs are in-line. I have to change the metering plate each time (and that's a real treat).

I was strongly considering whipping out the drill bits for some "adjustment" to metering plates. But I was afraid one of my friends would stop by, slap my hand and give me a speech about how they are rated on flow, not drill bit size, so I didn't.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-04-2009, 01:56 AM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,263
Wiki Edits: 326

Thanks: 610
Thanked 770 Times in 660 Posts
Quote:
Originally Posted by full mcgillicutty
I was strongly considering whipping out the drill bits for some "adjustment" to metering plates. But I was afraid one of my friends would stop by, slap my hand and give me a speech about how they are rated on flow, not drill bit size, so I didn't.
These are the same guys you're trying to drive around, right? Tell 'em to go pi** up a rope and do whatever you want to. You'll never be the fastest if you do the same thing everybody else does.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-04-2009, 02:45 AM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 7,678
Wiki Edits: 0

Thanks: 10
Thanked 149 Times in 137 Posts
Quick Fuel (and possibly others) sell a billet replacement metering plate that takes regular Holley jets, it fits into the same space as the fixed metering stock plate and allows you to make easy changes. If you've got several metering plates, I wouldn't be afraid to drill the jet orifice, it isn't quite the same as a Jet is, as long as you have a pair of plates to go back to -- drill away! You might have to experiment to win, like the Inspector said!

I'll agree with others and say fatten it up to see what happens.

On the blower drive ratio, I was just thinking off the top of my head it seemed like a lot by drag racing terms, wasn't thinking about your shorter race. Still might be worth a call to the maker of your blower's tech line and see what they say about the drive speed %. You may well be correct because of the low amount of time at full boost.

Just a thought --What size orifice needle and seats? You may have good pressure before the needle and seat but are drying up the bowls because the needles can't flow enough?? Also, since you are inline mounted, what about fuel slosh away from the jets in the rear bowls, especially at your acceleration speed?? This relates to 4000 rpm off the Brake and it is flat, fuel going to the back of the rear bowls instantly at the hit and away from the jets??

Last edited by ericnova72; 07-04-2009 at 03:02 AM.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-04-2009, 09:09 AM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Wow...Thanks Eric. I really got to start keeping up with new developments (I'm old ya know). Only thing I was aware of was the metering block conversion, did not know about the plate. Here's a summit link in case anyone else might want the same thing. http://www.summitracing.com/parts/QFT-34-3/

The drive ratio advice came from Dyers...Actually, I take that back, when I told him what it was on, and what it was going to be used for...he suggested I overdrive it quite a shot more than I have it now. I "only" went 11% over, thinking it be more controllable.

As far as the needle and seats go, that is most certainly a good thought. I don't even remember what size they are, I do know that they came from quick fuel. I did not consider them to be an issue, due to the fact that it's a relatively small motor and I did not think it would drain the bowls in such a short amount of time, as long as it has some fuel going to it.

Someone at the track brought up the idea of the fuel pulling away from the plates in the rear. After a bunch of talk, we came to the idea that even with it leaving hard, the "jets" are so low in the plate that if the float height was set right, it would not be able to pull away from them. I sure would like to hear your thoughts on this. As surprising as it is...sand draggers leave very hard. I am nowhere near the fastest Jeep (okay, it's an altered with an aluminum jeep skin hooked to it) and I'll run a 1.29 60 foot if the track is wet (a little wet is faster for us). Do you think it could pull away?

I am just going to start jetting up before I do anything else. I just like to have a bunch of other possibilities, you guys have given me a few, and than you for that.

Now, I am going to run the quick fuel plate (already ordered them) but I was curious to what the thought are when it comes to drilling metering plates. I have been told forever that it's a no no on jets (but I still did it ) Is it the general consensus that it's not as crucial on metering plates?
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-04-2009, 12:21 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 7,678
Wiki Edits: 0

Thanks: 10
Thanked 149 Times in 137 Posts
With a 1.29 sixty foot, that is good 8.5 second or faster 1/4 mile territory for a drag car, and it would be mandatory to have jet extensions in the rear bowl starting at roughly a 1.55 sixty foot. At the 60' your turning, all the fuel is instantly all up against the back wall of the bowl. Put a few inches of water in a 1 gallon pail, set it on the floor, and give it a shove and watch what the water does in the initial move of the bucket. It's pretty enlightening, gas in the bowl does the same thing.

Several of my tuning sources give drilling the metering plate as a tuning option, then buy the correct plate once you find the necessary orifice sizes. They also made mention of the inability of installing jet extensions to the factory plate being a detriment.

We've got a Sand Dragway here in Michigan on the Lake Michigan coast 2/3 the way up the Lower Peninsula at Silver Lake. A blast to watch, surprisingly fast!!
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 07-04-2009, 12:53 PM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
This is the first time I have had carbs in-line (not sideways) on a car that leaves this hard. I have some jet extensions I made stashed in my shop somewhere.
With the quick fuel conversion, I should be able to run them (might have to mod the floats.)

I'm getting close to the point of splurging for a couple of 750's and turning them sideways. Doing it the right way in other words.

Since I am not filthy rich...I always try and work with what I already have (which would explain the 660's) but sometimes it reaches a point where I would have been money ahead to use something different. This may end up being the case with the carbs.

I have raced at silver lake. I had an air-cooled dragster at the time. Some very fast stuff over there.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 07-04-2009, 03:08 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 7,678
Wiki Edits: 0

Thanks: 10
Thanked 149 Times in 137 Posts
I would think jet extensions and the ability to jet the secondary side will set the 660's right up. They are a very good carb for the blower or tunnel ram set-ups.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 07-04-2009, 04:59 PM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ericnova72
I would think jet extensions and the ability to jet the secondary side will set the 660's right up. They are a very good carb for the blower or tunnel ram set-ups.
Oh, I'm gonna give them a whirl with them set up right before doing any drastic changes. I have always liked the 660's.

Next race/test and tune won't be until July twenty (something). That's what is bad about having a sand drag racer...You have to either wait until a test and tune or find a large field.

I only live on two acres, so I can't really let it stretch it's legs, but I can test a launch.

I'll get back toy you guys about what fixed it and what jets I ended up with.

Thanks a lot for your help.
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 07-11-2009, 08:37 AM
Registered User
 
Join Date: Jul 2009
Location: Washington
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Alright guys...here's an update and some corrections on the information that I gave previously.

I'll start off by saying that I purchased the quick fuel metering plate conversion kits (very nice, thanks again). I went with center hung floats and bowls, notched floats and jet extensions. This is all stuff the altered needed done, so it did not matter if it fixed my problem or not...but it would have been nice.

On the first go round, I inadvertently gave some bad info.

I told you that it was missing only when it's under load. That is incorrect. I am not a huge fan of free revving my engine hard, which is why I thought it was just doing this under load.

I would "blip" the throttle and it would snap from 1,500 rpm to 6,000 in the blink of an eye...So I just said to myself "no problem there". Well, what I was doing was just cracking open the primary throttle plates for that "blip".

When at the track, I caught myself doing the same thing. Holding it against the brake with the primaries and a split second before lifting my finger, I mash it. I have been doing this kind of thing so long that I am sort of on autopilot and don't really even notice what I am doing.

Okay, so the new info is as follows. As I said previously, I changed to the quick fuel metering plates and jetted everything up. When the lay down spot would not change (noticeably) in the rpm range by jetting, I figured I would start to look elsewhere.

Going against my grain...I free revved it...HARD (ugh) and it falls flat as soon as the secondary plates start to open.

In example....I can run the engine up to where the secondaries are just about to open (I can feel it in my foot and see the linkage because it's right in front of me) the instant I just crack the secondaries, it lays down like it hit a rev limiter (sounds just like it as a matter of fact).

I was thinking about having the Wife stare down the carbs at the secondary booster to see if any fuel was coming out...but then I had a thought of having to cook my own food and wash my shorts after a blower backfire cut her down in her prime.

With the engine idling, I grabbed the secondary shaft and slowly eased just one set of secondaries open. The rpm did change and start to come up a bit...but it was very rough and would only gain a few RPM before hitting a spot when it was running so bad it would not gain anymore.

So on to my thoughts. It's very clear it's not clogged secondary jets (everything in there is new). The float level is perfect on both. I'm thinking there may be an obstruction in the body?

The reason I have not jumped right on this before coming here is that it seems a bit odd for both carbs to have the same clog, right? I mean, it's most certainly possible, but the odds are not really great.

So any thoughts before I pull them and start blowing them out?
Reply With Quote Quick reply to this message
  #15 (permalink)  
Old 07-11-2009, 11:18 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 7,678
Wiki Edits: 0

Thanks: 10
Thanked 149 Times in 137 Posts
Has anybody messed with the shape of the cam(the primary linkage "fan") that opens the secondaries? The 660's should be quite close to 1-1 rate with the primary about 10 degrees ahead of the secondaries.

You are using the 4-hole center squirter type squirter nozzles?? 50cc pumps on the carbs??

Check gasket used at main body to metering plate to make sure the passages all line up?? The metal seperator plate is present between the metering plate and the main body??

Just random thoughts as they come to me, does sound as if fuel is not being fed to the boosters in the rears.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
acceleration flat spot in carb. corvettetonybone Engine 17 04-13-2013 08:31 PM
4.6 DOHC In A 32: Anyone Did/Doing It 345 desoto Engine 13 12-19-2008 08:03 AM
SF oil???? n-gin Engine 6 07-09-2008 01:37 PM
intake leak? cope Engine 4 05-08-2008 07:59 PM
Is this blower god enough to keep my engine in its normal temp range Indian Engine 4 09-03-2003 02:56 AM


All times are GMT -6. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.