LED turn signals don't work - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-26-2010, 07:56 AM
bentwings's Avatar
bentwings
 
Last photo:
Join Date: May 2002
Location: St.Paul, Minn
Age: 72
Posts: 1,798
Wiki Edits: 0

Thanks: 0
Thanked 16 Times in 15 Posts
LED turn signals don't work

I have a pair of mirrors (Calif Smoothie) with LED turn signals built in. I also have single LED dash indicator lights for turn and high beams.

The dash LED's work fine. I simply connected them to the turn and high beam wires that were in the Painless wire harness.

Then I connected the mirror LED grounds to a separate ground terminal on a grounding board. (fiberglass car) The power wire is connected the matching indicator wire of the dash units.

The mirror LED's don't flash or light when power is applied. I verified that there is flashing power to both sides with my VOM.

Next I tried an "electronic" flasher. Nothing changed. My regular signals and high beam work just fine.

Do I need some kind of resistance in the line to the mirrors??

I'm going to pull them out today and see if I can get them to work on the bench.

Anybody got anytips??
No support from the mfg.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-26-2010, 10:51 AM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,840
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
That is what I was going to suggest, check them independent of the cars wiring. you might also reverse polarity while you have them on the bench to see if that may be the case.

Vince
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-26-2010, 11:28 AM
540z's Avatar
Brute force and ignorance.....
 
Last photo:
Join Date: Sep 2005
Location: Upstate NY
Posts: 57
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
How much voltage are you seeing on your meter at the mirrors? Do you know if the LED array in the mirrors has built in limiting resistors to drop the voltage to a safe voltage for the LEDs? Did you try reversing the leads (pos to neg and neg to pos)? LEDs are polarity sensitive, so they'll work in one direction, but not in the other. Let's start with the voltage to the mirrors.
TR
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yankee Turnflex Turn Signals R. Builder Electrical 4 06-07-2008 03:10 PM
no turn signals fasteddiesage Electrical 9 12-16-2005 04:04 PM
Problems with my turn signals and front lights 74_Chevrolet Electrical 3 08-29-2005 11:14 PM
Turn signals won't shut off after turning! 1meancuda Electrical 2 09-01-2004 01:48 PM


All times are GMT -6. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.