let us make this the last one - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-13-2004, 10:16 PM
New Member
 
Join Date: Aug 2004
Location: louisville, kentucky
Posts: 10
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
let us make this the last one

i hope that this will be the last post for this 97 geo metro. i need to move on to better things. the last time i posted a message, i was having problems with this metro of my wife's where it was wanting to not start after it has been running. a couple of you out there suggested that the egr was at fault. since that post, i tested and cleaned out the egr valve and replaced a special vac./ elec. post that is located under the egr modulator. i got out to run it and the dumb thing again acted up. it is only doing this when the weather is warm or hot. upon returning from the local grocery store, it would run fine for a couple of minutes and then start sputtering. the engine would all of a sudden drop to its idle speed and if i try to give it gas, the engine would act all retarded like it was getting too much gas. as soon as the car would coast to a stop, the car would die. i would have to get out and take off the air filter cover and it would restart (most of the time). it is getting gas and is falling in the specs. for fuel pressure. what am i missing here? it is something so close and in all likely hood very simple but i am missing it. help?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-13-2004, 10:36 PM
E.T. divided by $ spent= Speed
 
Last photo:
Join Date: May 2002
Location: NYS america's unwiped butt
Age: 34
Posts: 1,858
Wiki Edits: 0

Thanks: 0
Thanked 5 Times in 5 Posts
monte's cure all guide to FI computer engines

Plugs,wires,cap,rotor and fuel filter if it don't run then,flat tow it to Pep Boy's.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-14-2004, 09:58 PM
61ChevyTruck's Avatar
Yeah, I did set-off your alarm
 
Join Date: Feb 2004
Location: redding
Age: 27
Posts: 127
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I once had a geo storm, they had the notorious problem of when the ECU was made a coating was sprayed on the top of the circuit board, but a few years down the road the substance sprayed on the circuit board expanded when it got hot and broke a few solders, caused and effect like that, it was a *****, i also had a problem where i couldn't go over a certain rmp or it would just die, acted up after it was hot, solution to that one, Ingnition Module i tested my old one and they said it was still good i said screw it i'll just get a new one anyways, sure as **** i never had a problem till i hurled it down a ditch and totaled the damn thing!!!!!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-15-2004, 07:54 PM
New Member
 
Join Date: Aug 2004
Location: louisville, kentucky
Posts: 10
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I MAY HAVE TO AGREE WITH THAT ONE. WHATEVER THE PROBLEM IS, I FIGURE THAT IT IS ELECTRONIC IN NATURE (ONLY SHUTS DOWN IN THE HEAT OR WHEN IT GETS REAL HOT UNDE THE HOOD) AND THE WAY IT ACTS WHEN THIS HAPPENS. ENGINE GOES TO A IDLE MODE AND IF YOU PRESS ON THE GAS PEDAL TO GO AGAIN, THE ENGINE WILL DEACELLERATE. ******THING I HAVE EVER SEEN. ACTS LIKE A VAPOR LOCK.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-16-2004, 10:41 PM
GSXMEN's Avatar
Member
 
Last photo:
Join Date: Feb 2004
Location: Upstate, NY
Age: 49
Posts: 152
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Might not hurt to run a compression test, so you know where you stand there.

I don't know if the '97 Geo Metro still had the 3 cyl. engine or not. If so, I'll warn you that the exhaust valves are notorious for either burning or warping.

When you have the head done, plan on 3 new exh. valves.....the intakes most likely can be reground.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.