Light tap noise when left hand turn is made - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-27-2007, 02:18 PM
Registered User
 
Join Date: Apr 2007
Location: Aurora, Colorado
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Light tap noise when left hand turn is made

Have a 1967 Ford mustang with power steering and sometimes when making a left turn it makes a light solid tap that sounds like it is coming from the right side underneath the car. It does not do this when making a right hand turn. Could this possibly be the idler arm? Thanks

    Advertisement

Last edited by Bill Riese; 11-27-2007 at 02:46 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-27-2007, 05:08 PM
dtcandyman's Avatar
Registered User
 

Last journal entry: Time to let go
Last photo:
Join Date: Mar 2006
Location: ma
Age: 46
Posts: 23
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Re:tapping noise

I'd check the stabilizer links. They are known for making a ton of noise in any car...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-28-2007, 11:18 AM
Registered User
 
Join Date: Apr 2007
Location: Aurora, Colorado
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Light tap noise

Hello, thanks for the info. By checking you mean condition and torque on the end links? They are new, but didn't use a torque wrench. According to shop manual they are supposed to be 5-11 lbs on the end links and 17-25 lbs.for sway bar bushings to frame. As soon as weather warms up, I will check those.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-28-2007, 11:35 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 17,045
Wiki Edits: 5

Thanks: 24
Thanked 338 Times in 260 Posts
I would think that the stabilizer links would rattle more when you hit a bump rather than turning. I would think I would be checking my wheel bearings....maybe loose, maybe bad. Or, something loose in the brake drum.
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-29-2007, 01:47 PM
dtcandyman's Avatar
Registered User
 

Last journal entry: Time to let go
Last photo:
Join Date: Mar 2006
Location: ma
Age: 46
Posts: 23
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
trust me...i never thought stabilizer links could make such a noise...but mine did,just taking a turn at slow speeds...like while entering a parking spot.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 11-29-2007, 03:13 PM
Registered User
 
Join Date: Apr 2007
Location: Aurora, Colorado
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Light tap noise

I was just out in the garage looking ay my sway bar and end links and am wondering if I put the sway bar in upside down. Looks OK but am not sure. Anyway, is there a way you can tell?
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
this is a saver.... GM build codes TooMany2count General Rodding Tech 24 11-23-2009 10:36 AM
Weird Light problems TurboS10 Electrical 6 11-03-2007 08:29 PM
left tail light flashing too fast 88 nova gal Electrical 7 01-21-2005 06:23 PM
Light Problems like crazy ponybuster Electrical 7 10-14-2003 01:12 PM
valvetrain gurus: need help identifying mysterious valve noise blndweasel Engine 10 03-04-2003 08:59 PM


All times are GMT -6. The time now is 04:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.